1 { pkgs, lib, config, inputs, hostName, ... }:
4 inherit (config) networking;
5 inherit (config.services) gitolite;
6 inherit (config.users) users groups;
7 gitolite-admin = "julm";
10 environment.systemPackages = [ pkgs.gitolite ];
14 group = users."git".name;
16 builtins.readFile (inputs.secrets + "/members/ssh/julm.pub") +
17 builtins.readFile (inputs.secrets + "/members/ssh/julm-losurdo.pub");
19 $RC{UMASK} = 0027; # NOTE: no quote around in Perl, so it's octal
20 $RC{LOG_DEST} = 'repo-log,syslog';
21 $RC{LOG_FACILITY} = 'local0';
22 #$RC{GIT_CONFIG_KEYS} = 'hooks.* gitweb.*';
23 $RC{GIT_CONFIG_KEYS} = '.*';
24 #$RC{LOCAL_CODE} = "$rc{GL_ADMIN_BASE}/local"
25 # if -d "$rc{GL_ADMIN_BASE}/local";
26 $RC{LOCAL_CODE} = "$ENV{HOME}/local";
27 push(@{$RC{ENABLE}}, ( 'Alias'
29 # NOTE: without this "cgit" option,
30 # the repositories' "description" files are not modified
32 , 'Shell ${gitolite-admin}'
34 , 'expand-deny-messages'
36 , 'keysubdirs-as-groups'
38 , (-d "$ENV{HOME}/local" ? 'repo-specific-hooks' : ())
39 , 'ssh-authkeys-split'
43 fileSystems."/var/lib/gitolite" = {
44 device = "${hostName}/var/git";
47 services.sanoid.datasets."${hostName}/var/git" = {
48 use_template = [ "local" ];