]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/mermet/hardware.nix
nix: update inputs
[sourcephile-nix.git] / hosts / mermet / hardware.nix
1 { pkgs, lib, config, inputs, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/hardware/apu2e4.nix
5 (inputs.julm-nix + "/nixos/profiles/zramSwap.nix")
6 ];
7
8 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
9 # You should try to make this id unique among your hosts.
10 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
11 networking.hostId = "69c40b03";
12
13 boot.loader.grub.devices = [
14 "/dev/disk/by-id/ata-Samsung_SSD_840_EVO_250GB_S1DBNSAF340110R"
15 ];
16
17 fileSystems."/boot" =
18 { device = "/dev/disk/by-uuid/dc3c5387-17d2-43b3-bfa2-bf73afacca07";
19 fsType = "ext2";
20 };
21
22 fileSystems."/boot/efi" =
23 { device = "/dev/disk/by-uuid/62E6-E65F";
24 fsType = "vfat";
25 };
26
27 swapDevices = [
28 { device = "/dev/disk/by-partuuid/6b1eaa35-776b-4e60-b21e-7bcee535dd8b";
29 randomEncryption = {
30 enable = true;
31 cipher = "aes-xts-plain64";
32 source = "/dev/urandom";
33 };
34 }
35 ];
36 }