]> Git — Sourcephile - sourcephile-nix.git/blob - nixos/modules.nix
nix: rename install to install.ssh-nixos
[sourcephile-nix.git] / nixos / modules.nix
1 { pkgs, lib, config, ... }:
2 # NOTE: list explicitely the modules loaded by defaults.nix,
3 # its clearer, safer and more flexible if not quicker.
4 {
5 imports = [
6 modules/install/ssh-nixos.nix
7 modules/security/pass.nix
8 modules/services/networking/domains.nix
9 #modules/services/networking/knot.nix
10 modules/services/databases/openldap.nix
11 modules/services/mail/public-inbox.nix
12 #modules/services/mail/mlmmj.nix
13 ];
14 disabledModules = [
15 "services/mail/public-inbox.nix"
16 "services/mail/mlmmj.nix"
17 ];
18 }
19
20 /*
21 # NOTE: this modules.nix file is put in the imports of the configuration.nix,
22 # but using the lib.findFiles defined in the nixpkgs.overlays leads to an infinite recursion,
23 # hence it is redefined here:
24 let findFiles = pattern:
25 with builtins;
26 let go = curr:
27 let dir = readDir curr; in
28 let files = lib.filterAttrs (name: type:
29 type == "regular" &&
30 match pattern name != null) dir; in
31 let dirs = lib.filterAttrs (name: type: type == "directory") dir; in
32 map (name: "${curr}/${name}") (attrNames files) ++
33 lib.concatMap (name: go "${curr}/${name}") (attrNames dirs)
34 ;
35 in go ;
36 in
37 {
38 imports = findFiles ".*\\.nix" ./modules;
39 }
40 */