]> Git — Sourcephile - sourcephile-nix.git/blob - machines/losurdo/fileSystems.nix
cryptpad: add service
[sourcephile-nix.git] / machines / losurdo / fileSystems.nix
1 { pkgs, lib, config, machineName, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/systems/zfs.nix
5 ];
6
7 fileSystems."/" =
8 { device = "${machineName}/root";
9 fsType = "zfs";
10 };
11
12 fileSystems."/home" =
13 { device = "${machineName}/home";
14 fsType = "zfs";
15 };
16
17 fileSystems."/home/julm" =
18 { device = "${machineName}/home/julm";
19 fsType = "zfs";
20 };
21
22 fileSystems."/home/julm/work" =
23 { device = "${machineName}/home/julm/work";
24 fsType = "zfs";
25 };
26
27 fileSystems."/nix" =
28 { device = "${machineName}/nix";
29 fsType = "zfs";
30 };
31
32 fileSystems."/var" =
33 { device = "${machineName}/var";
34 fsType = "zfs";
35 };
36
37 fileSystems."/var/cache" =
38 { device = "${machineName}/var/cache";
39 fsType = "zfs";
40 };
41
42 fileSystems."/var/log" =
43 { device = "${machineName}/var/log";
44 fsType = "zfs";
45 };
46
47 fileSystems."/var/lib/nginx" =
48 { device = "${machineName}/var/www";
49 fsType = "zfs";
50 };
51
52 fileSystems."/var/lib/postgresql" =
53 { device = "${machineName}/var/postgresql";
54 fsType = "zfs"; # with sync=always,
55 # though loading OpenConcerto's initial SQL
56 # takes 1m40s instead of 40s :\
57 };
58
59 fileSystems."/var/lib/transmission" =
60 { device = "${machineName}/var/torrents";
61 fsType = "zfs";
62 };
63
64 fileSystems."/var/tmp" =
65 { device = "${machineName}/var/tmp";
66 fsType = "zfs";
67 };
68 }