1 { pkgs, lib, config, servers, ... }:
3 inherit (builtins) hasAttr readFile;
4 inherit (pkgs.lib) unlinesAttrs;
5 inherit (config.users) users groups;
8 networking.firewall.enable = false;
9 security.lockKernelModules = false;
10 systemd.services.disable-kernel-module-loading.after = [ "nftables.service" ];
11 # echo -e "$(nix eval servers.losurdo.config.networking.nftables.ruleset)"
13 networking.nftables = {
15 ruleset = lib.mkBefore ''
18 # Some .nix append rules here with: add rule inet filter net2fw ...
21 tcp dport {80,443} counter accept comment "HTTP"
22 udp dport 123 skuid ${users.systemd-timesync.name} counter accept comment "NTP"
23 tcp dport 9418 counter accept comment "Git"
25 # Some .nix append rules here with: add rule inet filter fw2net ...
29 type filter hook input priority 0
34 # accept traffic already established
35 ct state {established, related} accept
39 tcp dport 22 counter accept comment "SSH"
40 udp dport 60000-61000 counter accept comment "Mosh"
43 ip6 nexthdr icmpv6 icmpv6 type { destination-unreachable, packet-too-big, time-exceeded, parameter-problem, nd-router-advert, nd-neighbor-solicit, nd-neighbor-advert, mld-listener-query, nd-router-solicit } accept
44 ip protocol icmp icmp type { destination-unreachable, router-advertisement, time-exceeded, parameter-problem } accept
47 ip6 nexthdr icmpv6 icmpv6 type echo-request accept
48 ip protocol icmp icmp type echo-request accept
50 # Some .nix append gotos here with: add rule inet filter input iffname ... goto ...
53 type filter hook output priority 0
58 ct state {related,established} accept
61 icmp type echo-request counter accept comment "Ping"
62 tcp dport 22 counter accept comment "SSH"
64 # Some .nix append gotos here with: add rule inet filter output oifname ... goto ...
67 type filter hook forward priority 0