]> Git — Sourcephile - sourcephile-nix.git/blob - shell.nix
nix: shell: comment
[sourcephile-nix.git] / shell.nix
1 let
2 nixpkgs = import .lib/nix/nixpkgs.nix;
3 pkgs = import nixpkgs {
4 config = {}; # Make the config pure, ignoring user's config.
5 overlays = import ./overlays.nix;
6 };
7 lib = pkgs.lib;
8 nixos = pkgs.nixos {};
9
10 # Configuration of shell/modules/
11 configuration = {config, ...}: {
12 imports = [
13 ];
14 nix = {
15 nixConf = ''
16 auto-optimise-store = true
17 '';
18 };
19 nix-plugins = {
20 enable = true;
21 };
22 gnupg = {
23 enable = true;
24 gnupgHome = toString ../sec/gnupg;
25 keys = import shell/openpgp.nix;
26 };
27 openssl = {
28 enable = true;
29 opensslHome = toString ../sec/openssl;
30 certificates = import shell/x509.nix;
31 };
32 openssh = {
33 # WARNING: nixops uses its own ssh, not this one.
34 enable = true;
35 sshConf = ''
36 Ciphers aes256-gcm@openssh.com,aes128-gcm@openssh.com
37 Compression no
38 #CompressionLevel 4
39 ControlMaster auto
40 ControlPath ${builtins.toString ../sec/ssh}/ssh-%h-%p-%r.socket
41 HashKnownHosts no
42 #SSAPIAuthentication no
43 SendEnv LANG LC_*
44 StrictHostKeyChecking yes
45 UserKnownHostsFile ${builtins.toString ../sec/ssh/known_hosts}
46 '';
47 };
48 };
49
50 # Using modules enables to separate specific configurations
51 # from reusable code in shell/modules.nix and shell/modules/
52 # which may find its way in another git repository one day.
53 modules =
54 (import shell/modules.nix {
55 inherit pkgs lib;
56 modules = [ configuration ];
57 }).config;
58 in
59 pkgs.stdenv.mkDerivation {
60 name = "sourcephile-nix";
61 src = null;
62 #preferLocalBuild = true;
63 #allowSubstitutes = false;
64 buildInputs = modules.nix-shell.buildInputs ++ [
65 nixpkgs
66 nixos.nixos-generate-config
67 nixos.nixos-install
68 nixos.nixos-enter
69 #pkgs.binutils
70 pkgs.coreutils
71 pkgs.cryptsetup
72 pkgs.curl
73 #pkgs.direnv
74 pkgs.dnsutils
75 #pkgs.dropbear
76 pkgs.e2fsprogs
77 pkgs.git
78 pkgs.glibcLocales
79 pkgs.gnumake
80 pkgs.gnupg
81 pkgs.htop
82 #pkgs.inetutils
83 pkgs.ipcalc
84 #pkgs.iputils
85 pkgs.less
86 pkgs.libfaketime
87 #pkgs.mailutils
88 pkgs.man
89 pkgs.mdadm
90 pkgs.gptfdisk
91 pkgs.ncdu
92 pkgs.ncurses
93 pkgs.nixops
94 #pkgs.openssl
95 pkgs.pass
96 pkgs.procps
97 #pkgs.rxvt_unicode.terminfo
98 #pkgs.sqlite
99 pkgs.sqlite
100 pkgs.sudo
101 pkgs.tig
102 pkgs.time
103 #pkgs.tmux
104 pkgs.tree
105 pkgs.utillinux
106 pkgs.vim
107 #pkgs.virtualbox
108 pkgs.which
109 pkgs.xdg_utils
110 pkgs.zfs
111 pkgs.fio
112 pkgs.strace
113 pkgs.utillinux
114 #pkgs.zfstools
115 ];
116 #enableParallelBuilding = true;
117 shellHook = ''
118 echo >&2 "nix: running shellHook"
119
120 # Cleanup "../sec/tmp/"
121 # This is done when exiting the nix-shell
122 # (or when… entering the directory with direnv
123 # which spawns a nix-shell just to get the env).
124 trap "cd '$PWD' && find ../sec/tmp -type f -exec shred -fu {} +" EXIT
125
126 ${modules.nix-shell.shellHook}
127
128 # nix
129 export NIX_PATH="nixpkgs=${nixpkgs}"
130 NIX_PATH+=":nixpkgs-overlays="$PWD"/overlays"
131 #NIX_PATH+=""
132
133 # executables
134 PATH_NIX=$(dirname $(readlink -e ~/.nix-profile/bin/nix))
135 PATH_NIXOS=/run/wrappers/bin
136 PATH_FHS="$PWD"/.lib/nix/fhs-bin
137 PATH_FHS_VBOX="$PWD"/.lib/fhs-vbox-bin
138 export PATH="$PATH_NIXOS:$PATH_FHS_VBOX:$PATH_FHS:$PATH:$PATH_NIX"
139
140 # NOTE: sudo needs to be own by root with the setuid bit,
141 # but this won't be the case for the sudo provided by Nix outside NixOS,
142 # hence the addition of $PATH_FHS in shellHook
143 # to provide the host system's sudo.
144 # WARNING: beware that sudo may reset the environment,
145 # and especially PATH, to some system's default.
146
147 # locales
148 export LANG=fr_FR.UTF-8
149 export LC_CTYPE=fr_FR.UTF-8
150
151 # password-store
152 export PASSWORD_STORE_DIR="$PWD"/../sec/pass
153
154 # git
155 gitdir="$PWD"/.git
156 test ! -f "$gitdir" || while IFS=" :" read -r hdr gitdir; do [ "$hdr" != gitdir ] || break; done <"$gitdir"
157 ln -fnsr \
158 "$PWD"/.lib/git/hooks/prepare-commit-msg--longuest-common-prefix \
159 "$gitdir"/hooks/prepare-commit-msg
160
161 # nixops
162 #export NIXOPS_DEPLOYMENT="staging"
163 export NIXOPS_STATE="$PWD"/../sec/nixops/state.nixops
164 NIXOPS_OPTS+=" --show-trace"
165 export NIXOPS_OPTS
166
167 # disnix
168 #export DISNIXOS_USE_NIXOPS=1
169 #export DISNIX_CLIENT_INTERFACE=disnix-nixops-client
170 #export DISNIX_PROFILE=default
171 #export DISNIX_TARGET_PROPERTY=hostname
172 #export DYSNOMIA_STATEDIR="$PWD"/../sec/dysnomia
173 '';
174 }