]> Git — Sourcephile - sourcephile-nix.git/blob - install/physical/nixos.nix
update openldap, dovecot, postfix.
[sourcephile-nix.git] / install / physical / nixos.nix
1 {
2 friot = {pkgs, config, ...}: {
3 deployment.targetHost = "1.2.3.4";
4 deployment.autoLuks = {
5 # NOTE: not working on virtualbox deployment
6 secretdisk = {
7 device = "/dev/sda";
8 passphrase = "foobar";
9 autoFormat = true;
10 cipher = "aes-cbc-essiv:sha256";
11 };
12 };
13 networking.zones = {
14 net = {
15 iface = null;
16 ipv4 = null;
17 };
18 lan = {
19 iface = null;
20 ipv4 = null;
21 };
22 };
23 };
24 }