]> Git — Sourcephile - sourcephile-nix.git/blob - servers/losurdo/production.nix
sanoid: syncoid: fix upstream
[sourcephile-nix.git] / servers / losurdo / production.nix
1 { pkgs, lib, config, ... }:
2 let
3 inherit (builtins.extraBuiltins) pass;
4 inherit (config) networking;
5 in
6 {
7 imports = [
8 ../../base/dl10j.nix
9 production/networking.nix
10 production/fileSystems.nix
11 production/shorewall.nix
12 production/syncoid.nix
13 production/sanoid.nix
14 ];
15 deployment = {
16 targetEnv = "none";
17 targetHost = (builtins.elemAt networking.interfaces.enp5s0.ipv4.addresses 0).address;
18 keys = {
19 "id_ed25519" = {
20 text = pass "servers/losurdo/root/ssh/id_ed25519";
21 user = "root";
22 group = "root";
23 destDir = "/root/.ssh";
24 permissions = "0400";
25 };
26 };
27 };
28 }