]> Git — Sourcephile - sourcephile-nix.git/blob - machines/losurdo/hardware.nix
zfs: add a mirror SSD disk
[sourcephile-nix.git] / machines / losurdo / hardware.nix
1 { pkgs, lib, config, machineName, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/hardware/dl10j.nix
5 ../../nixos/profiles/systems/zramSwap.nix
6 ];
7
8 # The 32-bit host id of the machine, formatted as 8 hexadecimal characters.
9 # You should try to make this id unique among your machines.
10 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
11 networking.hostId = "e18f71a6";
12
13 boot.loader.grub.devices = [
14 #"/dev/disk/by-id/nvme-Samsung_SSD_970_EVO_Plus_250GB_S4EUNJ0N211426T"
15 #"/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
16 #"/dev/disk/by-id/mmc-SB32G_0xdb5e2237"
17 "/dev/disk/by-id/ata-Samsung_SSD_860_EVO_250GB_S3YJNX0K863141Y"
18 ];
19
20 fileSystems."/boot" =
21 { device = "/dev/disk/by-partlabel/${machineName}_ssd_boot";
22 fsType = "ext2";
23 };
24
25 fileSystems."/boot/efi" =
26 { device = "/dev/disk/by-partlabel/${machineName}_ssd_efi";
27 fsType = "vfat";
28 };
29
30 swapDevices = [
31 { device = "/dev/disk/by-partlabel/${machineName}_nvme_swap";
32 randomEncryption = {
33 enable = true;
34 cipher = "aes-xts-plain64";
35 source = "/dev/urandom";
36 };
37 }
38 { device = "/dev/disk/by-partlabel/${machineName}_ssd_swap";
39 randomEncryption = {
40 enable = true;
41 cipher = "aes-xts-plain64";
42 source = "/dev/urandom";
43 };
44 }
45 ];
46 }