1 { pkgs, lib, config, machineName, ... }:
4 ../../nixos/profiles/systems/zfs.nix
8 # Use arc_summary to print stats
9 "zfs.zfs_arc_max=${toString (1500 * 1024 * 1024)}" # bytes
13 { device = "${machineName}/root";
18 { device = "${machineName}/home";
22 fileSystems."/home/julm" =
23 { device = "${machineName}/home/julm";
27 fileSystems."/home/julm/work" =
28 { device = "${machineName}/home/julm/work";
33 { device = "${machineName}/nix";
38 { device = "${machineName}/var";
42 fileSystems."/var/cache" =
43 { device = "${machineName}/var/cache";
47 fileSystems."/var/log" =
48 { device = "${machineName}/var/log";
52 fileSystems."/var/lib/nginx" =
53 { device = "${machineName}/var/www";
57 fileSystems."/var/lib/postgresql" =
58 { device = "${machineName}/var/postgresql";
59 fsType = "zfs"; # with sync=always,
60 # though loading OpenConcerto's initial SQL
61 # takes 1m40s instead of 40s :\
64 fileSystems."/var/lib/transmission" =
65 { device = "${machineName}/var/torrents";
69 fileSystems."/var/tmp" =
70 { device = "${machineName}/var/tmp";