]> Git — Sourcephile - sourcephile-nix.git/blob - machines/losurdo/nginx/sourcephile.fr/losurdo.nix
tor: improve type-checking and hardening (ter)
[sourcephile-nix.git] / machines / losurdo / nginx / sourcephile.fr / losurdo.nix
1 { domain, ... }:
2 { pkgs, lib, config, ... }:
3 let
4 inherit (config) networking;
5 inherit (config.security) gnupg;
6 inherit (config.services) nginx;
7 srv = "losurdo";
8 onion = "dfc66yn2fundui5yvq2ndx4nmcmbxpho4ji32tlc4cncrjvs2b5yu4id";
9 in
10 {
11 services.tor = {
12 relay.onionServices."nginx/${domain}/${srv}" = {
13 secretKey = gnupg.secrets."tor/onion/${onion}/hs_ed25519_secret_key".path;
14 map = [
15 80
16 #{ port = 443; target = { port = 8443; }; }
17 ];
18 authorizedClients = [
19 "descriptor:x25519:2EZQ3AOZXERDVSN6WO5LNSCOIIPL2AT2A7KOS4ZIYNVQDR5EFM2Q" # julm
20 ];
21 };
22 client.onionServices.${onion} = {
23 clientAuthorizations = [
24 gnupg.secrets."tor/auth/julm".path
25 ];
26 };
27 };
28 security.gnupg.secrets."tor/onion/${onion}/hs_ed25519_secret_key" = {};
29 security.gnupg.secrets."tor/auth/julm" = {};
30 services.nginx = {
31 virtualHosts."${srv}" = {
32 serverName = "${srv}.${domain}";
33 serverAliases = [ domain "${onion}.onion" ];
34 listen = [
35 { addr="127.0.0.1"; port = 80; ssl = false; }
36 { addr="[::1]"; port = 80; ssl = false; }
37 { addr="0.0.0.0"; port = 8443; ssl = true; }
38 { addr="[::]"; port = 8443; ssl = true; }
39 ];
40 #onlySSL = true;
41 #forceSSL = true;
42 addSSL = true;
43 useACMEHost = domain;
44 root = "/var/lib/nginx";
45 extraConfig = ''
46 access_log /var/log/nginx/${domain}/${srv}/access.log json buffer=32k;
47 error_log /var/log/nginx/${domain}/${srv}/error.log warn;
48 '';
49 locations."/".extraConfig = ''
50 autoindex off;
51 '';
52 locations."/julm".extraConfig = ''
53 autoindex on;
54 fancyindex on;
55 fancyindex_exact_size off;
56 fancyindex_name_length 255;
57 '';
58 locations."/sevy".extraConfig = ''
59 auth_basic "sevy's area";
60 auth_basic_user_file ${gnupg.secrets."nginx/sevy/htpasswd".path};
61 autoindex off;
62 '';
63 };
64 };
65 systemd.services.nginx = {
66 serviceConfig.LogsDirectory = lib.mkForce ["nginx/${domain}/${srv}"];
67 wants = [ gnupg.secrets."nginx/sevy/htpasswd".service ];
68 after = [ gnupg.secrets."nginx/sevy/htpasswd".service ];
69 };
70 security.gnupg.secrets."nginx/sevy/htpasswd" = {
71 # Generated with: echo "$user:$(openssl passwd -apr1)"
72 user = nginx.user;
73 group = nginx.group;
74 };
75 }