]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/losurdo/fileSystems.nix
nix: update to latest nixpkgs
[sourcephile-nix.git] / hosts / losurdo / fileSystems.nix
1 { pkgs, lib, config, hostName, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/systems/zfs.nix
5 ];
6
7 fileSystems."/" = {
8 device = "${hostName}/root";
9 fsType = "zfs";
10 };
11 boot.zfs.requestEncryptionCredentials = [ hostName ];
12
13 fileSystems."/nix" = {
14 device = "${hostName}/nix";
15 fsType = "zfs";
16 };
17
18 fileSystems."/var" = {
19 device = "${hostName}/var";
20 fsType = "zfs";
21 };
22
23 fileSystems."/var/cache" = {
24 device = "${hostName}/var/cache";
25 fsType = "zfs";
26 };
27
28 fileSystems."/var/log" = {
29 device = "${hostName}/var/log";
30 fsType = "zfs";
31 };
32
33 fileSystems."/var/tmp" = {
34 device = "${hostName}/var/tmp";
35 fsType = "zfs";
36 };
37
38 fileSystems."/mnt/key" = {
39 device = "/dev/disk/by-label/key";
40 fsType = "vfat";
41 options = [ "auto" "nofail" "uid=1000" "gid=users" "umask=111" "dmask=007" "utf8=yes" ];
42 };
43
44 # Allow members of the "adbusers" group to mount Android devices via MTP
45 services.udev.packages = [ pkgs.android-udev-rules ];
46 environment.systemPackages = [
47 pkgs.go-mtpfs
48 pkgs.ntfs3g
49 ];
50
51 }