1 { pkgs, lib, config, ... }:
3 hardware.cpu.amd.updateMicrocode = true;
5 # Too CPU hungry for the APU2, for too little Mio saved
6 autoOptimiseStore = false;
9 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
11 # https://insanity.industries/post/sata-power-consumption/
12 services.udev.extraRules = ''
13 SUBSYSTEM=="scsi_host", KERNEL=="host*", ATTR{link_power_management_policy}="med_power_with_dipm"
21 configurationLimit = 1;
23 # In case canTouchEfiVariables doesn't work
24 #efiInstallAsRemovable = true;
26 # Completed in the importing configuration
30 { devices = [ "${disk_id}" ];
31 path = "/boot${bootnum}";
38 canTouchEfiVariables = true;
39 efiSysMountPoint = "/boot/efi";
45 availableKernelModules = [
53 # Make the AES modules available at initrd,
54 # to speedup the deciphering of the root.
67 "console=ttyS0,115200n8"
68 # Use arc_summary to print stats
69 #"zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
72 environment.systemPackages = [