2 network.rollBack = false;
3 friot = {pkgs, lib, config, options, ...}:
4 let ipv4 = if options.networking.privateIPv4.isDefined
5 then config.networking.privateIPv4
11 deployment.targetEnv = "virtualbox";
12 deployment.virtualbox.headless = true;
13 deployment.virtualbox.memorySize = 1024;
14 deployment.virtualbox.vcpu = 2;
15 deployment.virtualbox.disks.disk1.baseImage = <sys/var/virtualbox/nixops.vmdk>;
16 #deployment.virtualbox.disks.disk1.size = 6024;
17 # NOTE: resize not yet supported.
19 deployment.storeKeysOnMachine = true;
20 deployment.autoLuks = {
21 # NOTE: not working on virtualbox deployment
24 passphrase = "foobar";
26 cipher = "aes-cbc-essiv:sha256";
30 interfaces."enp0s8" = {
31 #macAddress = "00:11:22:33:44:55";
32 #ipv4.addresses = [ { address = ipv4; prefixLength = 32; } ];
33 ipv6.addresses = [ { address = "fe80::1"; prefixLength = 10; } ];