1 { pkgs, lib, config, system, ... }:
3 inherit (builtins) toString toFile readFile;
4 inherit (builtins.extraBuiltins) pass;
6 inherit (pkgs.lib) loadFile unlines unlinesAttrs unlinesValues unwords;
7 inherit (config) networking;
8 inherit (config.services) dovecot2 postfix openldap;
10 # NOTE: nixpkgs' dovecot2.stateDir is currently not exported
11 stateDir = "/var/lib/dovecot";
13 sieve_pipe_bin_dir = pkgs.buildEnv {
14 name = "sieve_pipe_bin_dir";
15 pathsToLink = [ "/bin" ];
21 learn-spam = pkgs.writeShellScriptBin "learn-spam.sh" ''
22 exec ${pkgs.rspamd}/bin/rspamc -h /run/rspamd/learner.sock learn_spam
24 learn-ham = pkgs.writeShellScriptBin "learn-ham.sh" ''
25 exec ${pkgs.rspamd}/bin/rspamc -h /run/rspamd/learner.sock learn_ham
28 dovecot-virtual = pkgs.buildEnv {
29 name = "dovecot-virtual";
30 pathsToLink = [ "/" ];
33 dovecot-virtual-recents
36 dovecot-virtual-all = pkgs.writeTextFile {
37 name = "dovecot-virtual-all";
38 destination = "/All/dovecot-virtual";
44 dovecot-virtual-recents = pkgs.writeTextFile {
45 name = "dovecot-virtual-recents";
46 destination = "/Recents/dovecot-virtual";
52 dovecot-virtual-pop3 = pkgs.writeTextFile {
53 name = "dovecot-virtual-pop3";
54 destination = "/pop3/INBOX/dovecot-virtual";
64 dovecot/sourcephile.fr.nix
65 dovecot/autogeree.net.nix
67 users.groups.acme.members = [ dovecot2.user ];
68 systemd.services.dovecot2 = {
75 # SEE: http://wiki2.dovecot.org/SharedMailboxes/Permissions
76 install -D -d -m 0771 \
77 -o "${dovecot2.user}" \
78 -g "${dovecot2.group}" \
83 #users.users."${dovecot2.mailUser}".isSystemUser = true; # Fix nixpkgs
87 pkgs.dovecot_pigeonhole
88 pkgs.dovecot_fts_xapian
94 protocols = [ "sieve" ];
95 # If needed, may be overrided by userdb_mail= in passdb, or mail= in userdb
96 # Here INDEX and CONTROL are separated,
97 # it's not useful since there is no quota at the filesystem level
98 # it's just to let this possibility later on.
99 mailLocation = "sdbox:${stateDir}/home/%d/%n/mail:UTF-8:CONTROL=${stateDir}/control/%d/%n:INDEX=${stateDir}/index/%d/%n";
100 createMailUser = false;
103 sslServerCert = null;
105 global = dovecot/sieve/global;
112 log_timestamp = "%Y-%m-%d %H:%M:%S "
115 ssl_dh = <${../../../sec/openssl/dh.pem}
116 ssl_cipher_list = HIGH:!LOW:!SSLv2:!EXP:!aNULL
117 ssl_prefer_server_ciphers = yes
118 ssl_cert = </var/lib/acme/${networking.domain}/fullchain.pem
119 ssl_key = </var/lib/acme/${networking.domain}/key.pem
120 #ssl_ca = <''${caPath}
121 #ssl_verify_client_cert = yes
124 mail_home = ${stateDir}/home/%d/%n
125 # Read multiple mails in parallel, improves performance
126 mail_prefetch_count = 20
127 # Default VSZ (virtual memory size) limit for service processes. This is mainly
128 # intended to catch and kill processes that leak memory before they eat up everything.
129 # Increased for fts_xapian.
130 default_vsz_limit = 1G
132 # DOC: https://doc.dovecot.org/configuration_manual/authentication/authentication_mechanisms/
133 # DOC: https://ldapwiki.com/wiki/DIGEST-MD5
134 # The misunderstanding is the notion "password sent over the network in plain-text" is not secure,
135 # when in fact, storing the password in the directory server using a Salted SHA-2 hash
136 # and transmitting the clear text password over a secure connection
137 # is more secure than having the directory server store the password in clear text
138 # or in a reversible encryption scheme.
139 # Therefore, SASL with DIGEST-MD5 (or CRAM-MD5) should be avoided.
140 # Use doveadm pw -s SSHA
141 # or doveadm pw -s PBKDF2 -r 10000
142 # or slappasswd -o module-load=pw-pbkdf2 -h "{PBKDF2-SHA256}"
143 auth_mechanisms = plain login
144 auth_username_format = %Ln
146 user = ${dovecot2.user}
147 # auth_socket_path points to this userdb socket by default. It's typically
148 # used by dovecot-lda, doveadm, possibly imap process, etc.
149 # Users that have access to this socket are able to get a list
150 # of all usernames and get results of everyone's userdb lookups.
151 unix_listener auth-userdb {
152 user = ${dovecot2.user}
153 group = ${dovecot2.group}
156 unix_listener /var/lib/postfix/queue/private/auth {
157 user = ${postfix.user}
158 group = ${postfix.group}
162 service auth-worker {
163 user = ${dovecot2.user}
165 auth_cache_verify_password_with_worker = yes
166 # SEE: http://wiki2.dovecot.org/Quota/FS
167 # NOTE: postfix does not supply a client cert.
168 auth_ssl_require_client_cert = no
169 #auth_ssl_username_from_cert = yes
170 # NOTE: lowercase the username, help with LDAP?
171 auth_username_format = %Lu
172 # NOTE: sync with LDAP's data.
173 first_valid_uid = 1000
174 disable_plaintext_auth = yes
178 # A different path than passdb's args enables non-blocking LDAP requests
179 args = ${pkgs.symlinkJoin {name="ldap"; paths=[./dovecot];}}/ldap.conf
184 # No dirty syncs for maildir: locations which may be used directly by neomutt
185 maildir_very_dirty_syncs = no
197 # NOTE: always listed in the LIST command.
199 # NOTE: how to access the other users' mailboxes.
200 # NOTE: %var expands to the logged in user's variable, while
201 # %%var expands to the other users' variables.
202 # NOTE: INDEX and CONTROL are shared, INDEXPVT is not.
203 location = sdbox:${stateDir}/home/%%d/%%n/${stateDir}/mail:UTF-8:CONTROL=${stateDir}/control/%%d/%%n/shared:INDEX=${stateDir}/index/%%d/%%n/shared:INDEXPVT=${stateDir}/index/%d/%n/shared/%%n
204 prefix = Partages+%%n+
208 mail_plugins = $mail_plugins virtual
215 location = virtual:${dovecot-virtual}:UTF-8:INDEX=${stateDir}/index/%d/%n/virtual
218 mail_plugins = $mail_plugins acl
220 acl = vfile:/etc/dovecot/acl/global
222 # NOTE: to let users LIST mailboxes shared by other users,
223 # Dovecot needs a shared mailbox dictionary.
224 # FIXME: %d not working with userdb ldap
225 acl_shared_dict = file:${stateDir}/acl/%d/acl.db
228 mail_plugins = $mail_plugins fts fts_xapian
230 # WARNING: doveadm fts rescan is buggy, it will delete the index:
231 # https://dovecot.org/pipermail/dovecot/2019-February/114709.html
232 # If need be, use rather: doveadm index -u "*@sourcephile.fr" -q '*'
233 plugin = fts fts_xapian
236 fts_autoindex_exclude = \Junk
237 fts_autoindex_exclude2 = \Trash
239 # 2 and 20 are the NGram values for header fields, which means the
240 # keywords created for fields (To, Cc, ...) are between is 2 and 20 chars long.
241 # Full words are also added by default.
242 fts_xapian = partial=2 full=20 attachments=1 verbose=0
243 fts_languages = en fr
244 #fts_dovecot_fs = posix:prefix=%h/fts/
247 mail_plugins = $mail_plugins quota
249 quota = maildir:User quota
250 quota_rule = *:storage=256M
251 quota_rule2 = Trash:storage=+64M
252 quota_max_mail_size = 20M
253 #quota_exceeded_message = </path/to/quota_exceeded_message.txt
254 quota_warning = storage=95%% quota-warning 95 %u
255 quota_warning2 = storage=80%% quota-warning 80 %u
256 quota_warning3 = -storage=100%% quota-warning below %u
260 hostname = ${networking.domain}
261 mail_plugins = $mail_plugins sieve
262 postmaster_address = postmaster+dovecot+lda@${networking.domain}
263 syslog_facility = mail
265 lda_mailbox_autocreate = yes
266 lda_mailbox_autosubscribe = yes
269 mail_plugins = $mail_plugins sieve
270 postmaster_address = postmaster+dovecot+lmtp@${networking.domain}
273 process_min_avail = ${toString config.nix.maxJobs}
274 unix_listener /var/lib/postfix/queue/private/dovecot-lmtp {
275 user = ${postfix.user}
276 group = ${postfix.group}
281 # Let extension.sieve do the handling of the detail
282 #lmtp_save_to_detail_mailbox = yes
283 recipient_delimiter = ${postfix.recipientDelimiter}
287 # Most of the memory goes to mmap()ing files.
288 # You may need to increase this limit if you have huge mailboxes.
293 #inet_listener imap {
294 # address = 127.0.0.1
298 inet_listener imaps {
303 # Store METADATA information within user's HOME directory
304 mail_attribute_dict = file:%h/dovecot-attributes
305 # If you have Dovecot v2.2.8+ you may get a significant performance improvement with fetch-headers:
306 imapc_features = $imapc_features fetch-headers
308 #mail_max_userip_connections = 10
309 mail_plugins = $mail_plugins imap_acl imap_quota imap_sieve virtual
312 # DOC: https://wiki.dovecot.org/MailboxSettings
313 # Due to a bug in Dovecot v2.2.30+ if special-use flags are used,
314 # SPECIAL-USE needs to be added to post-login CAPABILITY response as RFC 6154 mandates.
315 imap_capability = +SPECIAL-USE
320 special_use = \Archive
324 special_use = \Drafts
326 mailbox "Brouillons" {
328 special_use = \Drafts
343 mailbox "Pourriels" {
355 mailbox "Sent Items" {
359 mailbox "Sent Messages" {
372 mailbox "Corbeille" {
380 comment = All messages from all mailboxes
381 # This flag is confused with \Archives by K9-Mail
386 comment = All messages from all mailboxes, arrived in the past 48h
391 sieve_plugins = sieve_imapsieve sieve_extprograms
392 sieve_global_extensions = +vnd.dovecot.environment +vnd.dovecot.pipe
393 #sieve_extensions = +editheader
394 sieve = file:~/sieve;active=~/active.sieve
395 sieve_default = file:${stateDir}/sieve/global/default.sieve
396 sieve_default_name = main
397 sieve_pipe_bin_dir = ${sieve_pipe_bin_dir}/bin
398 sieve_max_script_size = 1M
399 sieve_quota_max_scripts = 0
400 sieve_quota_max_storage = 10M
401 #sieve_spamtest_max_value = 10
402 #sieve_spamtest_status_header = X-Spam-Score
403 #sieve_spamtest_status_type = strlen
404 #sieve_user_log = ~/sieve.log
405 # Enables support for user Sieve scripts in IMAP
406 #imapsieve_url = sieve://mail.${networking.domain}:4190
408 # When a flag changes, spam or ham according to the \Junk or \NonJunk flags
409 imapsieve_mailbox1_name = *
410 imapsieve_mailbox1_causes = FLAG
411 imapsieve_mailbox1_before = file:${stateDir}/sieve/global/spam-or-ham.sieve
413 # From elsewhere to Junk folder
414 imapsieve_mailbox2_name = Pourriel
415 imapsieve_mailbox2_causes = COPY APPEND
416 imapsieve_mailbox2_before = file:${stateDir}/sieve/global/report-spam.sieve
418 # From Junk folder to elsewhere
419 imapsieve_mailbox3_name = *
420 imapsieve_mailbox3_from = Pourriel
421 imapsieve_mailbox3_causes = COPY
422 imapsieve_mailbox3_before = file:${stateDir}/sieve/global/report-ham.sieve
425 # Maximum number of ManageSieve connections allowed for a user from each IP address.
426 # NOTE: The username is compared case-sensitively.
427 mail_max_userip_connections = 10
429 # To fool ManageSieve clients that are focused on CMU's timesieved you can specify
430 # the IMPLEMENTATION capability that the dovecot reports to clients.
431 # For example: 'Cyrus timesieved v2.2.13'
432 managesieve_implementation_string = Dovecot Pigeonhole
434 # The maximum number of compile errors that are returned to the client upon script
435 # upload or script verification.
436 managesieve_max_compile_errors = 5
438 #mail_max_userip_connections = 10
439 #managesieve_implementation_string = Dovecot Pigeonhole
440 managesieve_max_compile_errors = 5
441 #managesieve_max_line_length = 65536
442 #managesieve_notify_capability = mailto
443 #managesieve_sieve_capability = fileinto reject envelope encoded-character vacation subaddress comparator-i;ascii-numeric relational regex imap4flags copy include variables body enotify environment mailbox date ihave
445 service managesieve-login {
446 inet_listener sieve {
451 # Number of connections to handle before starting a new process. Typically
452 # the only useful values are 0 (unlimited) or 1. 1 is more secure, but 0
453 # is faster. <doc/wiki/LoginProcess.txt>
456 # Number of processes to always keep waiting for more connections.
457 process_min_avail = 0
459 # If you set service_count=0, you probably need to grow this.
463 service quota-warning {
464 executable = script ${
465 pkgs.writeShellScript "quota-warning" ''
469 cat << EOF | ${pkgs.dovecot}/libexec/dovecot/dovecot-lda -d $USER -o
470 "plugin/quota=maildir:User quota:noenforcing"
471 From: postmaster@${networking.domain}
472 Subject: [WARNING] your mailbox is now $PERCENT% full.
474 Please remove some mails to make room for new ones.
478 # use some unprivileged user for executing the quota warnings
479 user = ${dovecot2.user}
480 unix_listener quota-warning {
485 mail_plugins = $mail_plugins virtual
486 #mail_max_userip_connections = 10
487 # Virtual namespace for the virtual INBOX.
488 # Use a global directory for dovecot-virtual files.
492 # location = virtual:''${dovecot-virtual-pop3}/pop3:INDEX=${stateDir}/index/%d/%n/virtual/pop3:LAYOUT=fs
495 pop3_client_workarounds =
496 pop3_fast_size_lookups = yes
497 pop3_lock_session = yes
498 pop3_no_flag_updates = yes
499 # Use GUIDs to avoid accidental POP3 UIDL changes instead of IMAP UIDs.
500 pop3_uidl_format = %g
506 inet_listener pop3s {