]> Git — Sourcephile - sourcephile-nix.git/blob - bootstrap/mermet/etc/nixos/configuration.nix
nix: add bootstrap/mermet/
[sourcephile-nix.git] / bootstrap / mermet / etc / nixos / configuration.nix
1 # Edit this configuration file to define what should be installed on
2 # your system. Help is available in the configuration.nix(5) man page
3 # and in the NixOS manual (accessible by running ‘nixos-help’).
4
5 { config, pkgs, ... }:
6
7 {
8 imports =
9 [ ./hardware-configuration.nix
10 ./zfs-configuration.nix
11 ];
12
13 # networking.hostName = "nixos"; # Define your hostname.
14 # networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
15
16 # The global useDHCP flag is deprecated, therefore explicitly set to false here.
17 # Per-interface useDHCP will be mandatory in the future, so this generated config
18 # replicates the default behaviour.
19 networking.useDHCP = false;
20 networking.interfaces.eth0.useDHCP = true;
21
22 # Configure network proxy if necessary
23 # networking.proxy.default = "http://user:password@proxy:port/";
24 # networking.proxy.noProxy = "127.0.0.1,localhost,internal.domain";
25
26 # Select internationalisation properties.
27 # i18n = {
28 # consoleFont = "Lat2-Terminus16";
29 # consoleKeyMap = "us";
30 # defaultLocale = "en_US.UTF-8";
31 # };
32
33 # Set your time zone.
34 # time.timeZone = "Europe/Amsterdam";
35
36 # List packages installed in system profile. To search, run:
37 # $ nix search wget
38 # environment.systemPackages = with pkgs; [
39 # wget vim
40 # ];
41
42 # Some programs need SUID wrappers, can be configured further or are
43 # started in user sessions.
44 # programs.mtr.enable = true;
45 # programs.gnupg.agent = { enable = true; enableSSHSupport = true; };
46
47 # List services that you want to enable:
48
49 # Enable the OpenSSH daemon.
50 # services.openssh.enable = true;
51
52 # Open ports in the firewall.
53 # networking.firewall.allowedTCPPorts = [ ... ];
54 # networking.firewall.allowedUDPPorts = [ ... ];
55 # Or disable the firewall altogether.
56 # networking.firewall.enable = false;
57
58 # Enable CUPS to print documents.
59 # services.printing.enable = true;
60
61 # Enable sound.
62 # sound.enable = true;
63 # hardware.pulseaudio.enable = true;
64
65 # Enable the X11 windowing system.
66 # services.xserver.enable = true;
67 # services.xserver.layout = "us";
68 # services.xserver.xkbOptions = "eurosign:e";
69
70 # Enable touchpad support.
71 # services.xserver.libinput.enable = true;
72
73 # Enable the KDE Desktop Environment.
74 # services.xserver.displayManager.sddm.enable = true;
75 # services.xserver.desktopManager.plasma5.enable = true;
76
77 # Define a user account. Don't forget to set a password with ‘passwd’.
78 # users.users.jane = {
79 # isNormalUser = true;
80 # extraGroups = [ "wheel" ]; # Enable ‘sudo’ for the user.
81 # };
82
83 # This value determines the NixOS release with which your system is to be
84 # compatible, in order to avoid breaking some software such as database
85 # servers. You should change this only after NixOS release notes say you
86 # should.
87 system.stateVersion = "19.09"; # Did you read the comment?
88
89 }
90