]> Git — Sourcephile - sourcephile-nix.git/blob - bootstrap/mermet/etc/nixos/hardware-configuration.nix
nix: add bootstrap/mermet/
[sourcephile-nix.git] / bootstrap / mermet / etc / nixos / hardware-configuration.nix
1 # Do not modify this file! It was generated by ‘nixos-generate-config’
2 # and may be overwritten by future invocations. Please make changes
3 # to /etc/nixos/configuration.nix instead.
4 { config, lib, pkgs, ... }:
5
6 {
7 imports =
8 [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
9 ];
10
11 boot.initrd.availableKernelModules = [ "ehci_pci" "ahci" "uas" "sd_mod" ];
12 boot.initrd.kernelModules = [ "dm-snapshot" ];
13 boot.kernelModules = [ "kvm-intel" ];
14 boot.extraModulePackages = [ ];
15
16
17 # Use gc.automatic to keep disk space under control.
18 nix.autoOptimiseStore = true;
19 nix.gc.automatic = true;
20 #nix.gc.dates = "";
21 #nix.gc.options = "";
22
23 # Clean /tmp automatically on boot.
24 boot.cleanTmpDir = true;
25
26 fileSystems."/" =
27 { device = "rpool/root";
28 fsType = "zfs";
29 };
30
31 fileSystems."/boot" =
32 { device = "bpool/boot";
33 fsType = "zfs";
34 };
35
36 fileSystems."/boot/efi" =
37 { device = "/dev/disk/by-uuid/62E6-E65F";
38 fsType = "vfat";
39 };
40
41 fileSystems."/home" =
42 { device = "rpool/home";
43 fsType = "zfs";
44 };
45
46 fileSystems."/nix" =
47 { device = "rpool/nix";
48 fsType = "zfs";
49 };
50
51 fileSystems."/var" =
52 { device = "rpool/var";
53 fsType = "zfs";
54 };
55
56 fileSystems."/var/cache" =
57 { device = "rpool/var/cache";
58 fsType = "zfs";
59 };
60
61 fileSystems."/var/mail" =
62 { device = "rpool/var/mail";
63 fsType = "zfs";
64 };
65
66 fileSystems."/var/tmp" =
67 { device = "rpool/var/tmp";
68 fsType = "zfs";
69 };
70
71 fileSystems."/var/www" =
72 { device = "rpool/var/www";
73 fsType = "zfs";
74 };
75
76 swapDevices =
77 [ { device = "/dev/disk/by-uuid/ce776e6d-0a57-4d96-ad57-4b812ad6ab99"; }
78 ];
79
80 nix.maxJobs = lib.mkDefault 4;
81 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
82 }