]> Git — Sourcephile - sourcephile-nix.git/blob - shell.nix
nix: move .sec to ../sec and add pass-chomp
[sourcephile-nix.git] / shell.nix
1 let
2 nixpkgs = import .lib/nix/nixpkgs.nix;
3 pkgs = import nixpkgs {
4 config = {}; # Make the config pure, ignoring user's config.
5 overlays = import ./overlays.nix;
6 };
7 lib = pkgs.lib;
8 nixos = pkgs.nixos {};
9
10 # Configuration of shell/modules/
11 configuration = {config, ...}: {
12 imports = [
13 ];
14 nix = {
15 nixConf = ''
16 auto-optimise-store = true
17 '';
18 };
19 nix-plugins = {
20 enable = true;
21 };
22 gnupg = {
23 enable = true;
24 gnupgHome = toString ../sec/gnupg;
25 keys = import shell/openpgp.nix;
26 };
27 openssl = {
28 enable = true;
29 opensslHome = toString ../sec/openssl;
30 certificates = import shell/x509.nix;
31 };
32 openssh = {
33 enable = true;
34 sshConf = ''
35 Ciphers aes256-gcm@openssh.com,aes128-gcm@openssh.com
36 Compression yes
37 CompressionLevel 4
38 ControlMaster auto
39 ControlPath ${builtins.toString ../sec/ssh}/ssh-%h-%p-%r.socket
40 HashKnownHosts no
41 SSAPIAuthentication no
42 SendEnv LANG LC_*
43 StrictHostKeyChecking yes
44 UserKnownHostsFile ${builtins.toString ../sec/ssh/known_hosts}
45 '';
46 };
47 };
48
49 # Using modules enables to separate specific configurations
50 # from reusable code in shell/modules.nix and shell/modules/
51 # which may find its way in another git repository one day.
52 modules =
53 (import shell/modules.nix {
54 inherit pkgs lib;
55 modules = [ configuration ];
56 }).config;
57 in
58 pkgs.stdenv.mkDerivation {
59 name = "sourcephile-nix";
60 src = null;
61 #preferLocalBuild = true;
62 #allowSubstitutes = false;
63 buildInputs = modules.nix-shell.buildInputs ++ [
64 nixpkgs
65 nixos.nixos-generate-config
66 nixos.nixos-install
67 nixos.nixos-enter
68 #pkgs.binutils
69 pkgs.coreutils
70 pkgs.cryptsetup
71 pkgs.curl
72 #pkgs.direnv
73 #pkgs.dnsutils
74 #pkgs.dropbear
75 pkgs.e2fsprogs
76 pkgs.git
77 pkgs.glibcLocales
78 pkgs.gnumake
79 pkgs.gnupg
80 pkgs.htop
81 #pkgs.inetutils
82 pkgs.ipcalc
83 pkgs.less
84 pkgs.libfaketime
85 #pkgs.mailutils
86 pkgs.man
87 pkgs.mdadm
88 pkgs.gptfdisk
89 pkgs.ncdu
90 pkgs.ncurses
91 pkgs.nixops
92 #pkgs.openssl
93 pkgs.pass
94 pkgs.procps
95 #pkgs.rxvt_unicode.terminfo
96 #pkgs.sqlite
97 pkgs.sqlite
98 pkgs.sudo
99 pkgs.tig
100 pkgs.time
101 #pkgs.tmux
102 pkgs.tree
103 pkgs.utillinux
104 pkgs.vim
105 #pkgs.virtualbox
106 pkgs.which
107 pkgs.xdg_utils
108 pkgs.zfs
109 pkgs.fio
110 pkgs.strace
111 pkgs.utillinux
112 #pkgs.zfstools
113 ];
114 #enableParallelBuilding = true;
115 shellHook = ''
116 echo >&2 "nix: running shellHook"
117
118 # Cleanup "../sec/tmp/"
119 # This is done when exiting the nix-shell
120 # (or when… entering the directory with direnv
121 # which spawns a nix-shell just to get the env).
122 trap "cd '$PWD' && find ../sec/tmp -type f -exec shred -fu {} +" EXIT
123
124 ${modules.nix-shell.shellHook}
125
126 # nix
127 export NIX_PATH="nixpkgs=${nixpkgs}"
128 NIX_PATH+=":nixpkgs-overlays="$PWD"/overlays"
129 #NIX_PATH+=""
130
131 # executables
132 PATH_NIX=$(dirname $(readlink -e ~/.nix-profile/bin/nix))
133 PATH_NIXOS=/run/wrappers/bin
134 PATH_FHS="$PWD"/.lib/nix/fhs-bin
135 PATH_FHS_VBOX="$PWD"/.lib/fhs-vbox-bin
136 export PATH="$PATH_NIXOS:$PATH_FHS_VBOX:$PATH_FHS:$PATH:$PATH_NIX"
137
138 # NOTE: sudo needs to be own by root with the setuid bit,
139 # but this won't be the case for the sudo provided by Nix outside NixOS,
140 # hence the addition of $PATH_FHS in shellHook
141 # to provide the host system's sudo.
142 # WARNING: beware that sudo may reset the environment,
143 # and especially PATH, to some system's default.
144
145 # locales
146 export LANG=fr_FR.UTF-8
147 export LC_CTYPE=fr_FR.UTF-8
148
149 # password-store
150 export PASSWORD_STORE_DIR="$PWD"/../sec/pass
151
152 # git
153 gitdir="$PWD"/.git
154 test ! -f "$gitdir" || while IFS=" :" read -r hdr gitdir; do [ "$hdr" != gitdir ] || break; done <"$gitdir"
155 ln -fnsr \
156 "$PWD"/.lib/git/hooks/prepare-commit-msg--longuest-common-prefix \
157 "$gitdir"/hooks/prepare-commit-msg
158
159 # nixops
160 #export NIXOPS_DEPLOYMENT="staging"
161 export NIXOPS_STATE="$PWD"/../sec/nixops/state.nixops
162 NIXOPS_OPTS+=" --show-trace"
163 export NIXOPS_OPTS
164
165 # disnix
166 #export DISNIXOS_USE_NIXOPS=1
167 #export DISNIX_CLIENT_INTERFACE=disnix-nixops-client
168 #export DISNIX_PROFILE=default
169 #export DISNIX_TARGET_PROPERTY=hostname
170 #export DYSNOMIA_STATEDIR="$PWD"/../sec/dysnomia
171 '';
172 }