1 # NixOS configuration of losurdo.sourcephile.fr
2 # Domenico Losurdo (1941-2018), historian for the working class
3 # https://www.monde-diplomatique.fr/2018/10/FONDU/59128
4 { inputs, nixpkgsPath, ... }:
6 system = "x86_64-linux";
7 # Define pkgs explicitely to be able to set allowUnfree
8 pkgs = import nixpkgsPath {
10 config.allowUnfree = true; # For hplip
12 import ../nixpkgs/overlays.nix ++
13 import (inputs.julm-nix + "/nixpkgs/overlays.nix");
15 #config.allowUnfree = true;
18 config._module.args = {
23 ../nixos/profiles/systems/builder.nix
24 ../nixos/profiles/systems/debug.nix
27 #losurdo/discourse.nix
29 losurdo/fileSystems.nix
33 losurdo/networking.nix
36 losurdo/postgresql.nix
37 losurdo/prometheus.nix
40 #losurdo/sourcehut.nix
44 losurdo/transmission.nix
47 (inputs.secrets + "/hosts/losurdo/users.nix")