1 { pkgs, lib, config, ... }:
3 hardware.cpu.amd.updateMicrocode = true;
5 # Too CPU hungry for this hardware, for too little Mio saved
6 nix.autoOptimiseStore = false;
8 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
10 # https://insanity.industries/post/sata-power-consumption/
11 services.udev.extraRules = ''
12 SUBSYSTEM=="scsi_host", KERNEL=="host*", ATTR{link_power_management_policy}="med_power_with_dipm"
20 configurationLimit = 1;
22 # In case canTouchEfiVariables doesn't work
23 #efiInstallAsRemovable = true;
25 # Completed in the importing configuration
29 { devices = [ "${disk_id}" ];
30 path = "/boot${bootnum}";
37 canTouchEfiVariables = true;
38 efiSysMountPoint = "/boot/efi";
44 availableKernelModules = [
52 # Make the AES modules available at initrd,
53 # to speedup the deciphering of the root.
66 "console=ttyS0,115200n8"
67 # Use arc_summary to print stats
68 #"zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
71 environment.systemPackages = [