1 { pkgs, lib, config, ... }:
3 hardware.cpu.intel.updateMicrocode = true;
6 pkgs.intel-media-driver # LIBVA_DRIVER_NAME=iHD
7 pkgs.vaapiIntel # LIBVA_DRIVER_NAME=i965 (older but works better for Firefox/Chromium)
13 # Too CPU hungry for this hardware, for too little Mio saved
14 nix.autoOptimiseStore = false;
16 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
18 # https://insanity.industries/post/sata-power-consumption/
19 services.udev.extraRules = ''
20 SUBSYSTEM=="scsi_host", KERNEL=="host*", ATTR{link_power_management_policy}="med_power_with_dipm"
25 canTouchEfiVariables = false;
26 efiSysMountPoint = "/boot/efi";
32 configurationLimit = 9;
34 # Because canTouchEfiVariables doesn't work on this system
35 efiInstallAsRemovable = true;
37 # Completed in the importing configuration
41 { devices = [ "${disk_id}" ];
42 path = "/boot${bootnum}";
50 availableKernelModules = [
52 "ehci_pci" # useless ?
54 "mei_me" # Communication controller
55 "nvme" # NVME M.2 disk
56 #"rtl8188ee" # Wireless
57 "rtsx_usb_sdmmc" # SD card
58 #"snd_hda_intel" # Audio
63 # Make the AES modules available at initrd,
64 # to speedup the deciphering of the root.
71 "nvme" # NVME M.2 disk
72 "rtsx_usb_sdmmc" # SD card
73 "ums_realtek" # SD card
76 boot.kernelModules = [
77 "rtsx_usb_sdmmc" # SD card
78 "ums_realtek" # SD card
80 boot.extraModulePackages = [ ];
83 "console=ttyS0,115200n8"
84 "console=ttyS1,115200n8"
88 # rtlwifi/rtl8188efw.bin
89 hardware.enableRedistributableFirmware = true;
91 environment.systemPackages = with pkgs; [