1 { inputs, pkgs, lib, config, host, ... }:
4 inherit (config) networking;
5 inherit (config.services) nginx;
10 configs = lib.mkOption {
11 type = types.attrsOf types.lines;
14 Make some configs available to all virtual hosts.
15 Useful to workaround the reset of add_header:
16 https://blog.g3rt.nl/nginx-add_header-pitfall.html
18 #apply = lib.mapAttrs (name: pkgs.writeText "${name}.conf");
23 systemd.tmpfiles.rules = [
24 "d '/dev/shm/nginx' '750' '${nginx.user}' '${nginx.group}' - -"
26 systemd.services.nginx = {
27 requires = [ "systemd-tmpfiles-setup-dev.service" ];
29 # FIXME: remove all the mkForce in LogsDirectory
30 # whenever upstream uses a list instead of a string.
31 LogsDirectory = lib.mkForce ["nginx"];
32 StateDirectory = ["nginx"];
33 StateDirectoryMode = "2770";
34 #BindPaths = ["/dev/shm/nginx:/var/cache/nginx"];
37 services.logrotate = {
41 "/var/log/nginx/*.log"
42 "/var/log/nginx/*/*.log"
43 "/var/log/nginx/*/*/*.log"
44 "/var/log/nginx/*/*/*/*.log"
52 [ ! -f /var/run/nginx/nginx.pid ] || kill -USR1 `cat /var/run/nginx/nginx.pid`
61 worker_connections 1024;
63 clientMaxBodySize = "20m";
64 recommendedGzipSettings = true;
65 recommendedOptimisation = false;
66 recommendedProxySettings = true;
67 recommendedTlsSettings = true;
69 ipv6 = lib.mkDefault (networking.defaultGateway6 != null);
72 # Only allow PFS-enabled ciphers with AES256
73 #sslCiphers = "AES256+EECDH:AES256+EDH:!aNULL";
74 #sslCiphers = "HIGH:!ADH:!MD5:!CAMELLIA:!SEED:!3DES:!DES:!RC4:!eNULL";
75 #sslCiphers = "EECDH+aRSA+AESGCM:EDH+aRSA:EECDH+aRSA:+AES256:+AES128:+SHA1:!CAMELLIA:!SEED:!3DES:!DES:!RC4:!eNULL";
76 sslDhparam = inputs.secrets + "/openssl/dh.pem";
77 sslProtocols = "TLSv1.3 TLSv1.2";
81 #add_header Content-Security-Policy "script-src 'self'; object-src 'none'; base-uri 'none';" always;
83 # Enable XSS protection of the browser.
84 # May be unnecessary when CSP is configured properly (see above)
85 add_header X-XSS-Protection "1; mode=block";
87 # Minimize information leaked to other domains
88 add_header 'Referrer-Policy' 'origin-when-cross-origin';
90 # Restrict embedding as a frame
91 #add_header X-Frame-Options SAMEORIGIN;
93 # Prevent injection of code in other mime types (XSS Attacks)
94 add_header X-Content-Type-Options nosniff;
96 https_add_headers = ''
98 # Add HSTS header with preloading to HTTPS requests.
99 # Adding this header to HTTP requests is discouraged,
100 # as doing so makes the connection vulnerable to SSL stripping attacks
101 # DOC: https://blog.qualys.com/securitylabs/2016/03/28/the-importance-of-a-proper-http-strict-transport-security-implementation-on-your-web-server
102 add_header Strict-Transport-Security $hsts_header;
105 commonHttpConfig = ''
106 log_format main '$remote_addr - $remote_user [$time_local] "$request" '
107 '$status $body_bytes_sent "$http_referer" '
108 '"$http_user_agent" "$http_x_forwarded_for"';
109 log_format json escape=json '{'
110 '"time_local":"$time_local",'
112 '"request":"$request",'
113 '"status":"$status",'
114 '"http_referrer":"$http_referer",'
115 '"remote_addr":"$remote_addr",'
116 '"remote_user":"$remote_user",'
118 '"body_bytes_sent":"$body_bytes_sent",'
119 '"bytes_sent":"$bytes_sent",'
120 '"http_user_agent":"$http_user_agent",'
121 '"request_length":"$request_length",'
122 '"request_method":"$request_method",'
123 '"request_time":"$request_time",'
124 '"request_uri":"$request_uri",'
125 '"server_protocol":"$server_protocol",'
126 '"ssl_protocol":"$ssl_protocol",'
127 '"upstream_addr":"$upstream_addr",'
128 '"upstream_connect_time":"$upstream_connect_time",'
129 '"upstream_response_time":"$upstream_response_time"'
137 lib.concatStringsSep "\n" (lib.attrValues {
139 #default_type application/octet-stream;
143 #error_page 403 = 404;
145 ${nginx.configs.http_add_headers}
147 # This might create errors
148 #proxy_cookie_path / "/; secure; HttpOnly; SameSite=strict";
151 access_log /var/log/nginx/access.json json;
152 error_log /var/log/nginx/error.log warn;
153 open_log_file_cache max=1000 inactive=20s min_uses=2 valid=1m;
156 proxy_cache_use_stale updating;
157 proxy_temp_path /var/cache/nginx/proxy_temp 1 2;
160 # DOC: http://wiki.nginx.org/HttpFastcgiModule
161 fastcgi_buffer_size 128k;
162 fastcgi_buffers 256 4k;
163 fastcgi_busy_buffers_size 256k;
164 fastcgi_cache_key "$request_method $scheme://$http_host$request_uri";
165 fastcgi_connect_timeout 60;
166 fastcgi_ignore_client_abort off;
167 fastcgi_intercept_errors on;
168 fastcgi_max_temp_file_size 2M;
169 #fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
170 fastcgi_param SCRIPT_FILENAME $request_filename;
171 fastcgi_temp_path /var/cache/nginx/fastcgi_temp 1 2;
175 # If the client stops reading data,
176 # free up the stale client connection after this much time.
178 # Causes nginx to attempt to send its HTTP response head
179 # in one packet, instead of using partial frames.
180 # This is useful for prepending headers before calling sendfile,
181 # or for throughput optimization.
183 # Don't buffer data-sends (disable Nagle algorithm).
184 # Good for sending frequent small bursts of data in real time.
186 keepalive_timeout 20;
187 reset_timedout_connection on;
188 server_names_hash_bucket_size 128;
191 map $time_iso8601 $date {
192 default 'date-not-found';
193 '~^(?<year>\d{4})-(?<month>\d{2})-(?<day>\d{2})' $year-$month-$day;
196 map $scheme $hsts_header {
197 https "max-age=31536000; includeSubdomains; preload";
200 # User agents that are to be blocked.
201 #map $http_user_agent $bad_bot {
204 # ~(?i)(httrack|htmlparser|libwww) 1;
206 # Referrers that are to be blocked.
207 #map $http_referer $bad_referer {
209 # ~(?i)(babes|casino|click|diamond|forsale|girl|jewelry|love|nudit|organic|poker|porn|poweroversoftware|replica|sex|teen|webcam|zippo) 1;
217 client_body_buffer_size 4K;
220 client_body_temp_path /var/cache/nginx/client_body_temp 1 2;
221 client_body_timeout 60;
222 client_header_buffer_size 1k;
223 client_header_timeout 60;
224 large_client_header_buffers 4 8k;
226 open_file_cache max=200000 inactive=20s;
227 open_file_cache_errors on;
228 open_file_cache_min_uses 2;
229 open_file_cache_valid 30s;
233 worker_processes ${toString host.CPUs};