]> Git — Sourcephile - sourcephile-nix.git/blob - servers/losurdo/hardware.nix
transmission: fix net.core.{r,w}mem_max
[sourcephile-nix.git] / servers / losurdo / hardware.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/hardware/dl10j.nix
5 ];
6
7 # The 32-bit host id of the machine, formatted as 8 hexadecimal characters.
8 # You should try to make this id unique among your machines.
9 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
10 networking.hostId = "e18f71a6";
11
12 boot.loader.grub.devices = [
13 #"/dev/disk/by-id/nvme-Samsung_SSD_970_EVO_Plus_250GB_S4EUNJ0N211426T"
14 #"/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
15 "/dev/disk/by-id/mmc-SB32G_0xdb5e2237"
16 ];
17
18 fileSystems."/boot" =
19 { device = "/dev/disk/by-partlabel/losurdo_sd_boot";
20 fsType = "ext2";
21 };
22
23 fileSystems."/boot/efi" =
24 { device = "/dev/disk/by-partlabel/losurdo_sd_efi";
25 fsType = "vfat";
26 };
27
28 swapDevices = [
29 { device = "/dev/disk/by-partlabel/losurdo_nvme_swap";
30 randomEncryption = {
31 enable = true;
32 cipher = "aes-xts-plain64";
33 source = "/dev/urandom";
34 };
35 }
36 ];
37
38 zramSwap = {
39 enable = true;
40 algorithm = "zstd";
41 memoryPercent = 50;
42 swapDevices = 1;
43 };
44 }