]> Git — Sourcephile - sourcephile-nix.git/blob - servers/mermet/hardware.nix
transmission: fix net.core.{r,w}mem_max
[sourcephile-nix.git] / servers / mermet / hardware.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/hardware/apu2e4.nix
5 ];
6
7 # The 32-bit host id of the machine, formatted as 8 hexadecimal characters.
8 # You should try to make this id unique among your machines.
9 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
10 networking.hostId = "69c40b03";
11
12 boot.loader.grub.devices = [
13 "/dev/disk/by-id/ata-Samsung_SSD_840_EVO_250GB_S1DBNSAF340110R"
14 ];
15
16 fileSystems."/boot" =
17 { device = "/dev/disk/by-uuid/dc3c5387-17d2-43b3-bfa2-bf73afacca07";
18 fsType = "ext2";
19 };
20
21 fileSystems."/boot/efi" =
22 { device = "/dev/disk/by-uuid/62E6-E65F";
23 fsType = "vfat";
24 };
25
26 swapDevices = [
27 { device = "/dev/disk/by-partuuid/6b1eaa35-776b-4e60-b21e-7bcee535dd8b";
28 randomEncryption = {
29 enable = true;
30 cipher = "aes-xts-plain64";
31 source = "/dev/urandom";
32 };
33 }
34 ];
35
36 zramSwap = {
37 enable = true;
38 algorithm = "zstd";
39 memoryPercent = 50;
40 swapDevices = 1;
41 };
42 }