1 { pkgs, lib, config, hostName, ... }:
4 inherit (config) networking;
5 lanIPv4 = "192.168.1.215";
6 lanNet = "192.168.1.0/24";
7 lanIPv4Gateway = "192.168.1.1";
11 networking/nftables.nix
13 networking/wireguard/intranet.nix
14 networking/wireguard/extranet.nix
16 networking/nsupdate.nix
17 networking/wireless.nix
18 networking/openvpn.nix
21 boot.initrd.network = {
23 flushBeforeStage2 = true;
24 # This will automatically load the zfs password prompt on login
25 # and kill the other prompt so boot can continue
26 # The pkill zfs kills the zfs load-key from the console
27 # allowing the boot to continue.
29 echo >>/root/.profile "zfs load-key ${hostName} && pkill zfs"
33 /* WARNING: using ipconfig (the ip= kernel parameter) IS NOT RELIABLE:
34 a 91.216.110.35/32 becomes a 91.216.110.35/8
35 boot.kernelParams = map
36 (ip: "ip=${ip.clientIP}:${ip.serverIP}:${ip.gatewayIP}:${ip.netmask}:${ip.hostname}:${ip.device}:${ip.autoconf}")
37 [ { clientIP = netIPv4; serverIP = "";
38 gatewayIP = networking.defaultGateway.address;
39 netmask = "255.255.255.255";
40 hostname = ""; device = networking.defaultGateway.interface;
43 { clientIP = lanIPv4; serverIP = "";
45 netmask = "255.255.255.0";
46 hostname = ""; device = "enp2s0";
51 /* DIY network config, but a right one */
53 boot.initrd.preLVMCommands = ''
58 ip address add ${lanIPv4}/32 dev enp5s0
59 ip route add ${lanIPv4Gateway} dev enp5s0
60 ip route add ${lanNet} dev enp5s0 src ${lanIPv4} proto kernel
61 # NOTE: ${lanIPv4}/24 would not work with initrd's ip, hence ${lanNet}
62 ip route add default via ${lanIPv4Gateway} dev enp5s0
65 #ip -6 address add ''${lanIPv6} dev enp5s0
66 #ip -6 route add ''${lanIPv6Gateway} dev enp5s0
67 #ip -6 route add default via ''${lanIPv6Gateway} dev enp5s0
77 # Workaround https://github.com/NixOS/nixpkgs/issues/56822
78 #boot.initrd.kernelModules = [ "ipv6" ];
80 # Useless without an out-of-band access, and unsecure
81 # (though / may still be encrypted at this point).
82 # boot.kernelParams = [ "boot.shell_on_fail" ];
85 # Disable IPv6 entirely until it's available
86 boot.kernel.sysctl = {
87 "net.ipv6.conf.enp5s0.disable_ipv6" = 1;
93 domain = "sourcephile.fr";
99 address = lanIPv4Gateway;
100 interface = "enp5s0";
103 address = lanIPv6Gateway;
104 interface = "enp5s0";
110 networking.nftables.ruleset = ''
111 add rule inet filter input iifname "enp5s0" goto net2fw
112 add rule inet filter output oifname "enp5s0" jump fw2net
113 add rule inet filter output oifname "enp5s0" log level warn prefix "fw2net: " counter drop
114 add rule inet filter fw2net ip daddr ${lanNet} log level info prefix "fw2net: lan: " counter accept comment "LAN"
115 add rule inet nat postrouting oifname "enp5s0" masquerade
117 boot.kernel.sysctl."net.ipv6.conf.enp5s0.addr_gen_mode" = 1;
119 security.gnupg.secrets."ipv6/enp5s0/stable_secret" = {};
120 # This is only active in stage2, the initrd will still use the MAC-based SLAAC IPv6.
121 system.activationScripts.ipv6 = ''
122 ${pkgs.procps}/bin/sysctl --quiet net.ipv6.conf.enp5s0.stable_secret="$(cat ${gnupg.secrets."ipv6/enp5s0/stable_secret".path})"
125 networking.interfaces.enp5s0 = {
128 ipv4.addresses = [ { address = lanIPv4; prefixLength = 24; } ];
130 ipv4.routes = [ { address = networking.defaultGateway.address; prefixLength = 32; } ];
131 ipv6.addresses = [ { address = lanIPv6; prefixLength = 64; }
132 { address = "fe80::1"; prefixLength = 10; }
134 ipv6.routes = [ { address = networking.defaultGateway6.address; prefixLength = 64; } ];