1 { pkgs, lib, config, hosts, ... }:
5 #gateway = config.networking.defaultGateway.interface;
8 environment.systemPackages = [
11 networking.interfaces.${iface} = {
12 ipv4.addresses = [ { address = "192.168.2.1"; prefixLength = 24; } ];
14 # Not merged, even though all are 1
15 #boot.kernel.sysctl."net.ipv4.ip_forward" = 1;
16 boot.kernel.sysctl."net.ipv6.conf.${iface}.addr_gen_mode" = 1;
17 networking.nftables.ruleset = ''
18 add chain inet filter wifi2fw
19 add chain inet filter fw2wifi
20 add rule inet filter input iifname "${iface}" goto wifi2fw
21 add rule inet filter output oifname "${iface}" goto fw2wifi
23 # ${iface} firewalling
24 add rule inet filter fw2wifi counter accept
26 # Allow forwarding to the internet
27 add rule inet filter forward iifname "${iface}" oifname "${gateway}" counter accept
28 add rule inet filter forward iifname "${gateway}" oifname "${iface}" counter accept
30 # Allow networking services
31 add rule inet filter wifi2fw meta l4proto { udp, tcp } th dport 53 counter accept comment "DNS"
32 add rule inet filter wifi2fw tcp dport 67 counter accept comment "DHCP"
35 services.unbound.settings = {
37 interface = [ "192.168.2.1" ];
38 access-control = ["192.168.2.0/24 allow"];
40 "tracking.intl.miui.com always_refuse"
41 "sourcephile.fr typetransparent"
44 "\"bureau1.sourcephile.fr A 192.168.2.1\""
49 networking.wlanInterfaces.${iface} = {
54 networking.networkmanager.unmanaged = [
56 "interface-name:${iface}"
60 # iw dev wlp4s0 station dump
61 # DOC: https://w1.fi/cgit/hostap/plain/hostapd/hostapd.conf
69 wpaPassphrase = "bidonpoissonmaisonronron";
74 dtim_period=2 # DTIM (delivery trafic information message)
76 # limit the frequencies used to those allowed in the country
78 # 0 means the AP will search for the channel with the least interferences (ACS)
85 auth_algs=1 # 0=noauth, 1=wpa, 2=wep, 3=both
87 # QoS support, also required for full speed on 802.11n/ac/ax
89 eap_reauth_period=360000
96 # See Capabilities in iw list
97 ht_capab=[HT40+][SHORT-GI-40][DSSS_CCK-40][MAX-AMSDU-7935]
105 systemd.services."dhcpd4" = {
106 after = [ "network-addresses-${iface}.service" ];
108 "network-addresses-${iface}.service"
109 "sys-subsystem-net-devices-${iface}.device"
114 interfaces = [ iface ];
116 option subnet-mask 255.255.255.0;
117 option broadcast-address 192.168.2.255;
118 option routers 192.168.2.1;
119 option domain-name-servers 192.168.2.1;
120 subnet 192.168.2.0 netmask 255.255.255.0 {
121 range 192.168.2.100 192.168.2.200;
126 #networking.firewall.allowedUDPPorts = [ 53 67 ]; # DNS & DHCP
128 # Sometimes slow connection speeds are attributed to absence of haveged.
129 services.haveged.enable = true;
134 systemd.services.wifi-relay = let inherit (pkgs) iptables gnugrep;
136 description = "iptables rules for wifi-relay";
137 after = [ "dhcpd4.service" ];
138 wantedBy = [ "multi-user.target" ];
140 ${iptables}/bin/iptables -w -t nat -I POSTROUTING -s 192.168.2.0/24 ! -o wlan-ap0 -j MASQUERADE
141 ${iptables}/bin/iptables -w -I FORWARD -i wlan-ap0 -s 192.168.2.0/24 -j ACCEPT
142 ${iptables}/bin/iptables -w -I FORWARD -i wlan-station0 -d 192.168.2.0/24 -j ACCEPT