1 { pkgs, lib, config, machineName, ... }:
4 ../../nixos/profiles/systems/zfs.nix
8 { device = "${machineName}/root";
11 boot.zfs.requestEncryptionCredentials = [ machineName ];
14 { device = "${machineName}/nix";
19 { device = "${machineName}/var";
23 fileSystems."/var/cache" =
24 { device = "${machineName}/var/cache";
28 fileSystems."/var/log" =
29 { device = "${machineName}/var/log";
33 fileSystems."/var/lib/nginx" =
34 { device = "${machineName}/var/www";
38 fileSystems."/var/lib/postgresql" =
39 { device = "${machineName}/var/postgresql";
40 fsType = "zfs"; # with sync=always,
41 # though loading OpenConcerto's initial SQL
42 # takes 1m40s instead of 40s :\
45 fileSystems."/var/lib/transmission" =
46 { device = "${machineName}/var/torrents";
50 fileSystems."/var/tmp" =
51 { device = "${machineName}/var/tmp";
55 fileSystems."/mnt/key" =
56 { device = "/dev/disk/by-label/key";
58 options = [ "auto" "nofail" "uid=1000" "gid=users" "umask=111" "dmask=007" "utf8=yes" ];
61 # Allow members of the "adbusers" group to mount Android devices via MTP
62 services.udev.packages = [ pkgs.android-udev-rules ];
63 environment.systemPackages = [