]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/carotte.nix
carotte: fix build
[sourcephile-nix.git] / hosts / carotte.nix
1 # NixOS configuration of carotte.sourcephile.fr
2 { inputs, hostName, ... }:
3 {
4 nixpkgs.hostPlatform = {
5 system = "armv7l-linux";
6 config = "armv7l-unknown-linux-gnueabihf";
7 };
8 imports = [
9 {
10 install.substituteOnDestination = false;
11 }
12 (inputs.julm-nix + "/nixos/profiles/builder.nix")
13 (inputs.julm-nix + "/nixos/profiles/lang-fr.nix")
14 (inputs.julm-nix + "/nixos/profiles/networking/remote.nix")
15 ../nixos/profiles/systems/debug.nix
16 #carotte/fileSystems.nix
17
18 carotte/hardware.nix
19 #carotte/hostapd.nix
20 carotte/networking.nix
21 carotte/security.nix
22 carotte/system.nix
23 carotte/users.nix
24 #(inputs.secrets + "/hosts/${hostName}/users.nix")
25 #carotte/xserver.nix
26 ];
27 }