1 { config, lib, pkgs, ... }:
7 cfg = config.networking.wireguard;
9 interfaceOpts = { config, ... }: {
10 options.peers = mkOption {
11 type = with types; listOf (submodule peerOpts);
13 options.peersAnnouncing = {
14 enable = mkEnableOption ''
15 announcing of peers' endpoints.
17 listenPort = mkOption {
19 defaultText = "<option>networking.wireguard.listenPort</option> or 51820 if null";
21 TCP port on which to listen for peers queries for other peers' endpoints.
24 This exposes the public key and current (or last known) endpoint address of all the peers
25 configured in the WireGuard interface, to all the peers,
26 and to any host connected to the peers or announcing peer
27 able to query the WireGuard interface
28 by spoofing the allowedIPs of any peer.
34 config.peersAnnouncing = {
35 listenPort = mkDefault (if config.listenPort == null then 51820 else config.listenPort);
39 peerOpts = { config, ... }: {
40 options.endpointsUpdater = {
41 enable = mkEnableOption ''
42 receiving the enpoint of other peers from a periodic TCP connection.
43 That connection is meant to be to a peer using <option>networking.wireguard.peersAnnouncing.enable</option>.
45 This is especially useful to punch-through non-symmetric NATs
46 effectively establishing peer-to-peer connectivity:
47 the peers initiate a Wireguard connection to the announcing peer,
48 then use that Wireguard tunnel to query the endpoints of the other peers
49 to establish Wireguard tunnels to them,
50 using UDP hole punching when both peers are behind non-symmetric NATs.
52 Note that it can also work for two peers behind the same NAT
53 if that NAT can reflect (to its internal network) connections
54 from its internal network to its external IP address,
55 which may require to set persistentKeepalive as low as 1
56 and/or redirecting at least one host's WireGuard port, eg. with UPnP.
60 defaultText = "address of the first item of the peer's <option>allowedIPs</option>";
62 Address at which to contact the announcing peer,
63 configured on the announcing peer's <option>networking.wireguard.ips</option>.
68 defaultText = "port of the peer's endpoint";
70 TCP port on which to contact the peer announcing other peers.
71 This is configured on the announcing peer's <option>networking.wireguard.peersAnnouncing.listenPort</option>.
74 refreshSeconds = mkOption {
75 type = with types; int;
79 Time to wait between two successive queries of the endpoints known by the peer.
84 config.endpointsUpdater = {
85 addr = mkDefault (head (builtins.match "^\([^/]*\).*$" (head (config.allowedIPs))));
86 port = mkDefault (toInt (head (builtins.match "^.*:\([0-9]*\)$" config.endpoint)));
90 keyToUnitName = replaceChars
91 [ "/" "-" " " "+" "=" ]
92 [ "-" "\\x2d" "\\x20" "\\x2b" "\\x3d" ];
94 peerUnitServiceName = interfaceName: publicKey: dynamicRefreshEnabled:
96 unitName = keyToUnitName publicKey;
97 refreshSuffix = optionalString dynamicRefreshEnabled "-refresh";
99 "wireguard-${interfaceName}-peer-${unitName}${refreshSuffix}";
102 # - systemd-analyze security wireguard-${iface}-peers-announcing@
103 # - systemd-analyze security wireguard-${iface}-endpoints-updater-${public_key}.service
104 # Note that PrivateUsers=true would be too restrictive wrt. capabilities.
105 peerUpdateSecurity = {
106 IPAddressDeny = "any";
108 AmbientCapabilities = [ "CAP_NET_ADMIN" ];
109 CapabilityBoundingSet = [ "CAP_NET_ADMIN" ];
110 RestrictNamespaces = true;
112 PrivateDevices = true;
114 ProtectControlGroups = true;
116 ProtectKernelLogs = true;
117 ProtectKernelModules = true;
118 ProtectKernelTunables = true;
119 ProtectProc = "invisible";
120 SystemCallArchitectures = "native";
121 # Remove (likely) unused groups from the basic @system-service group
132 RestrictRealtime = true;
133 LockPersonality = true;
134 MemoryDenyWriteExecute = true;
136 ProtectHostname = true;
140 generatePeersAnnouncingSocket = name: values:
141 nameValuePair "wireguard-${name}-peers-announcing"
143 enable = values.peersAnnouncing.enable;
144 listenStreams = [ (toString values.peersAnnouncing.listenPort) ];
145 socketConfig.Accept = true;
146 # Basic firewalling restricting answers to peers
147 # querying an internal IP address of the announcing peer.
148 # Note that IPv4 addresses can be spoofed using other interfaces unless
149 # sysctl net.ipv4.conf.${name}.rp_filter=1
150 socketConfig.BindToDevice = name;
151 socketConfig.IPAddressAllow = map (peer: peer.allowedIPs) values.peers;
152 socketConfig.IPAddressDeny = "any";
153 socketConfig.MaxConnectionsPerSource = 1;
154 socketConfig.ReusePort = true;
155 wantedBy = [ "sockets.target" ];
158 generatePeersAnnouncingUnit = name: values:
159 nameValuePair "wireguard-${name}-peers-announcing@"
161 description = "WireGuard Peers Announcing - ${name}";
162 requires = [ "wireguard-${name}.service" ];
163 after = [ "wireguard-${name}.service" ];
165 serviceConfig = mkMerge [
169 ExecStart = "${pkgs.wireguard-tools}/bin/wg show '${name}' endpoints";
170 StandardInput = "null";
171 StandardOutput = "socket";
172 RestrictAddressFamilies = "";
174 (mkIf (values.interfaceNamespace != null)
175 { NetworkNamespacePath = "/var/run/netns/${values.interfaceNamespace}"; })
179 generateEndpointsUpdaterUnit = { interfaceName, interfaceCfg, peer }:
181 dynamicRefreshEnabled = peer.dynamicEndpointRefreshSeconds != 0;
182 peerService = peerUnitServiceName interfaceName peer.publicKey dynamicRefreshEnabled;
184 nameValuePair "wireguard-${interfaceName}-endpoints-updater-${keyToUnitName peer.publicKey}"
186 description = "WireGuard ${interfaceName} Endpoints Updater - ${peer.publicKey}";
187 requires = [ "${peerService}.service" ];
188 after = [ "${peerService}.service" ];
189 wantedBy = [ "${peerService}.service" ];
190 path = with pkgs; [ wireguard-tools ];
193 StartLimitIntervalSec = 0;
195 serviceConfig = mkMerge [
199 IPAddressAllow = [ peer.endpointsUpdater.addr ];
200 RestrictAddressFamilies = [ "AF_INET" "AF_INET6" "AF_NETLINK" ];
201 Restart = "on-failure";
203 (mkIf (interfaceCfg.interfaceNamespace != null)
204 { NetworkNamespacePath = "/var/run/netns/${interfaceCfg.interfaceNamespace}"; })
207 # Query the peer announcing other peers
208 # for setting the current endpoint of all configured peers
209 # (but the announcing peer).
210 # Note that socat is used instead of libressl's netcat
211 # (which would require MemoryDenyWriteExecute=true to load libtls.so)
212 # or netcat-gnu (which does not work on ARM and has last been released in 2004).
214 wait="${toString peer.endpointsUpdater.refreshSeconds}"
215 declare -A configured_keys
216 configured_keys=(${concatMapStringsSep " " (p:
217 optionalString (p.publicKey != peer.publicKey) "[${p.publicKey}]=set")
221 # Set stdin to socat's stdout
222 exec < <(exec ${pkgs.socat}/bin/socat STDOUT \
223 "TCP:${with peer.endpointsUpdater; addr+":"+toString port}")
225 # Update the endpoint of each configured peer
226 while read -t "$wait" -n 128 -r public_key endpoint x; do
227 if [ "$endpoint" != "(none)" -a "''${configured_keys[$public_key]}" ]; then
228 wg set "${interfaceName}" peer "$public_key" endpoint "$endpoint"
241 options.networking.wireguard.interfaces = mkOption {
242 type = with types; attrsOf (submodule interfaceOpts);
245 config = mkIf cfg.enable (
249 (interfaceName: interfaceCfg:
250 map (peer: { inherit interfaceName interfaceCfg peer; }) interfaceCfg.peers
257 mapAttrs' generatePeersAnnouncingSocket cfg.interfaces;
260 mapAttrs' generatePeersAnnouncingUnit cfg.interfaces //
261 (listToAttrs (map generateEndpointsUpdaterUnit
262 (filter ({ peer, ... }: peer.endpointsUpdater.enable) all_peers)));