1 { pkgs, lib, config, host, ... }:
3 hardware.cpu.intel.updateMicrocode = true;
6 pkgs.intel-media-driver # LIBVA_DRIVER_NAME=iHD
7 pkgs.vaapiIntel # LIBVA_DRIVER_NAME=i965 (older but works better for Firefox/Chromium)
13 # Too CPU hungry for the DL10J, for too little Mio saved
14 autoOptimiseStore = false;
17 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
19 # https://insanity.industries/post/sata-power-consumption/
20 services.udev.extraRules = ''
21 SUBSYSTEM=="scsi_host", KERNEL=="host*", ATTR{link_power_management_policy}="med_power_with_dipm"
29 configurationLimit = 9;
31 # Because canTouchEfiVariables doesn't work on this system
32 efiInstallAsRemovable = true;
34 # Completed in the importing configuration
38 { devices = [ "${disk_id}" ];
39 path = "/boot${bootnum}";
45 canTouchEfiVariables = false;
46 efiSysMountPoint = "/boot/efi";
51 availableKernelModules = [
53 "ehci_pci" # useless ?
55 "mei_me" # Communication controller
56 "nvme" # NVME M.2 disk
57 #"rtl8188ee" # Wireless
58 "rtsx_usb_sdmmc" # SD card
59 #"snd_hda_intel" # Audio
64 # Make the AES modules available at initrd,
65 # to speedup the deciphering of the root.
72 "nvme" # NVME M.2 disk
73 "rtsx_usb_sdmmc" # SD card
74 "ums_realtek" # SD card
77 boot.kernelModules = [
78 "rtsx_usb_sdmmc" # SD card
79 "ums_realtek" # SD card
81 boot.extraModulePackages = [ ];
84 "console=ttyS0,115200n8"
85 "console=ttyS1,115200n8"
89 # rtlwifi/rtl8188efw.bin
90 hardware.enableRedistributableFirmware = true;
92 environment.systemPackages = with pkgs; [