]> Git — Sourcephile - sourcephile-nix.git/blob - overlays/servers/dns/nsd.nix
nix: update to latest nixos-unstable
[sourcephile-nix.git] / overlays / servers / dns / nsd.nix
1 self: super: {
2 nsd = (super.nsd.override {
3 mmap = true;
4 }).overrideDerivation (attrs: {
5 # DOC: https://www.raspberrypi.org/forums/viewtopic.php?t=223628
6 configureFlags = attrs.configureFlags ++ [
7 # Allow to listen on that number of addresses
8 "--with-max-ips=8"
9 # You can disable the radix tree and use the red-black
10 # tree for the main lookups, the red-black tree uses
11 # less memory, but uses some more CPU.
12 #"--disable-radix-tree"
13 # Enable packed structure alignment, uses less memory,
14 # but unaligned reads.
15 "--enable-packed"
16 ];
17 });
18 }