1 { pkgs, lib, config, ... }:
2 let inherit (lib) types;
3 inherit (config.networking) hostName domain;
9 defaults/predictable-interface-names.nix
12 #binaryCaches = lib.mkForce [];
15 autoOptimiseStore = lib.mkDefault true;
16 # Use gc.automatic to keep disk space under control.
18 automatic = lib.mkDefault true;
19 dates = lib.mkDefault "weekly";
20 options = lib.mkDefault "--delete-older-than 30d";
24 documentation.nixos = {
25 enable = false; # NOTE: useless on a server, and CPU intensive.
28 console.font = "Lat2-Terminus16";
29 console.keyMap = lib.mkDefault "fr";
30 i18n.defaultLocale = "fr_FR.UTF-8";
31 nixpkgs.config.allowUnfree = false;
32 time.timeZone = "Europe/Paris";
34 # Always try to start all the units (default.target)
35 # because systemd's emergency shell does not try to start sshd.
36 # https://wiki.archlinux.org/index.php/systemd#Disable_emergency_mode_on_remote_host
37 systemd.enableEmergencyMode = false;
39 # This is a remote headless server: always reboot on a kernel panic,
40 # to not have to physically go power cycle the apu2e4.
41 # Which happens if the wrong ZFS password is used
42 # but the boot is manually forced to continue.
43 # Using kernelParams instead of kernel.sysctl
44 # sets this up as soon as the initrd.
45 boot.kernelParams = [ "panic=10" ];
47 boot.cleanTmpDir = lib.mkDefault true;
48 boot.tmpOnTmpfs = lib.mkDefault true;
52 # See: https://github.com/NixOS/nixpkgs/issues/10183#issuecomment-537629621
54 "127.0.1.1" = lib.mkForce [ "${hostName}.${domain}" hostName ];
55 "::1" = lib.mkForce [ "${hostName}.${domain}" hostName "localhost" ];
58 usePredictableInterfaceNames = true;
64 passwordAuthentication = false;
69 MaxRetentionSec=1month
76 environment.systemPackages = with pkgs; [
79 config.boot.kernelPackages.cpupower
89 #mailutils # builds guile
109 environment.variables.SYSTEMD_LESS = "FKMRX";
110 environment.etc."inputrc".text = lib.readFile defaults/readline/inputrc;
114 interactiveShellInit = ''
115 bind '"\e[A":history-search-backward'
116 bind '"\e[B":history-search-forward'
118 # Ignore duplicate commands, ignore commands starting with a space
119 export HISTCONTROL=erasedups:ignorespace
120 export HISTSIZE=42000
122 # Append to the history instead of overwriting (good for multiple connections)
125 # Enable ** file pattern
129 mkcd() { mkdir -p "$1" && cd "$1"; }
130 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk '/MemAvailable/{ printf "%d\n", $2 * $fac; }' </proc/meminfo)k; }
131 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
132 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
133 zfs-mount () { for d in $(zfs list -rH -o name "$@"); do sudo zfs mount -l "$d"; done; }
134 zfs-unmount () { sudo zfs unmount -u "$@"; }
140 ls = "ls --color=tty";
141 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
142 mem-top = "smem --sort rss --reverse --autosize";
145 st="sudo systemctl status";
146 u="systemctl --user";
147 j="sudo journalctl -u";
149 nixos-clean="sudo nix-collect-garbage -d";
150 nixos-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
151 nixos-rollback="sudo nixos-rebuild switch --rollback";
152 nixos-update="sudo nix-channel --update";
153 nixos-upgrade="sudo nixos-rebuild switch";
154 nixos-upstream="sudo nix-channel --list";
157 gnupg.agent.pinentryFlavor = "curses";
158 mosh.enable = lib.mkDefault true;
159 mtr.enable = lib.mkDefault true;
160 traceroute.enable = lib.mkDefault true;