]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/losurdo.nix
hostapd: try to fix the network
[sourcephile-nix.git] / hosts / losurdo.nix
1 # NixOS configuration of losurdo.sourcephile.fr
2 # Domenico Losurdo (1941-2018), historian for the working class
3 # https://www.monde-diplomatique.fr/2018/10/FONDU/59128
4 { inputs, nixpkgsPath, ... }:
5 rec {
6 system = "x86_64-linux";
7 # Define pkgs explicitely to be able to set allowUnfree
8 pkgs = import nixpkgsPath {
9 inherit system;
10 config.allowUnfree = true; # For hplip
11 overlays =
12 import ../nixpkgs/overlays.nix ++
13 import (inputs.julm-nix + "/nixpkgs/overlays.nix");
14 };
15 #config.allowUnfree = true;
16 modules = [
17 {
18 config._module.args = {
19 CPUs = 2;
20 };
21 }
22 ../nixos/defaults.nix
23 ../nixos/profiles/systems/builder.nix
24 ../nixos/profiles/systems/debug.nix
25 losurdo/acme.nix
26 losurdo/apc.nix
27 #losurdo/discourse.nix
28 losurdo/fail2ban.nix
29 losurdo/fileSystems.nix
30 #losurdo/freeciv.nix
31 losurdo/gitolite.nix
32 losurdo/hardware.nix
33 losurdo/networking.nix
34 losurdo/nginx.nix
35 losurdo/postfix.nix
36 losurdo/postgresql.nix
37 losurdo/prometheus.nix
38 losurdo/sanoid.nix
39 losurdo/security.nix
40 #losurdo/sourcehut.nix
41 losurdo/sftp.nix
42 losurdo/syncoid.nix
43 losurdo/system.nix
44 losurdo/transmission.nix
45 losurdo/unbound.nix
46 losurdo/users.nix
47 (inputs.secrets + "/hosts/losurdo/users.nix")
48 losurdo/xserver.nix
49 ];
50 }