]> Git — Sourcephile - sourcephile-nix.git/blob - nixos/profiles/systems/builder.nix
carotte: use home-manager
[sourcephile-nix.git] / nixos / profiles / systems / builder.nix
1 { inputs, pkgs, lib, config, ... }:
2 {
3 nix.extraOptions = ''
4 experimental-features = nix-command flakes
5 '';
6 #nix.registry.self.flake = inputs.self;
7 # Pin the rev to the revision of the public Nixpkgs that the system was built from.
8 # This is the version which will be locked by flakes using flake:nixpkgs
9 nix.registry.nixpkgs = {
10 from = { id = "nixpkgs"; type = "indirect"; };
11 to = {
12 owner = "NixOS";
13 repo = "nixpkgs";
14 rev = inputs.nixpkgs.rev;
15 type = "github";
16 };
17 };
18 /*
19 # WARNING: this is a hack to avoid copying Nixpkgs
20 # a second time into the Nix store.
21 # It makes only sense when Nixpkgs is already in the Nix store,
22 # and is registered.
23 environment.etc."nixpkgs".source = pkgs.path;
24 environment.etc."nixpkgs-overlays".source =
25 pkgs.writeTextDir "overlays.nix" ''
26 import ${inputs.self + "/nixpkgs/overlays.nix"} ++
27 import ${inputs.julm-nix + "/nixpkgs/overlays.nix"}
28 '';
29 nix.nixPath = [
30 "nixpkgs=/etc/nixpkgs:nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
31 ];
32 */
33 }