]> Git — Sourcephile - sourcephile-nix.git/blob - nixos/profiles/systems/crossCompilation.nix
carotte: use home-manager
[sourcephile-nix.git] / nixos / profiles / systems / crossCompilation.nix
1 { pkgs, lib, config, ... }:
2 {
3 nixpkgs.overlays = [
4 (final: super: {
5 # TODO: remove after liburing-2.1
6 liburing = super.liburing.overrideAttrs (old: {
7 src = super.fetchgit {
8 url = "http://git.kernel.dk/${old.pname}";
9 rev = "cb350a8989adbd65db574325d9a86d5437d800da";
10 sha256 = "sha256-ZMev2RjiswuR9seVwHbnVUtnpaPW/XJbelBgvIuYiGg=";
11 };
12 });
13 gnupg = super.gnupg.override {
14 # Wants polkit which wants spidermonkey (slow to compile)
15 pcsclite = null;
16 };
17 systemd = super.systemd.override {
18 # Wants tpm2-tss which does not cross-compile
19 withTpm2Tss = false;
20 # Does not cross-compile :(
21 withEfi = false;
22 };
23 # https://logs.nix.samueldr.com/nixos/2019-07-23#2416964;
24 xorg = super.xorg.overrideScope' (ofinal: osuper: {
25 fontadobe100dpi = final.hello;
26 fontadobe75dpi = final.hello;
27 fontcursormisc = final.hello;
28 fontmiscmisc = final.hello;
29 });
30 # Perl's ModuleBuild does not cross-compile
31 # https://github.com/NixOS/nixpkgs/issues/66741#issuecomment-944831760
32 xdg-utils = final.hello;
33 procmail = final.hello;
34 noto-fonts-emoji = final.hello;
35 x11_ssh_askpass = final.hello;
36 dconf = super.dconf.overrideAttrs (old: {
37 doCheck = false;
38 });
39 # Need gobject-instrospection which does not cross-compile
40 arandr = final.hello;
41 # Depends on judy which does not cross-compile
42 stress-ng = final.hello;
43 hwinfo = final.hello;
44 # Fails to cross-compile: perl5.34.0-IO-Tty-armv7l-unknown-linux-gnueabihf
45 mosh = final.hello;
46 })
47 ];
48 #environment.noXlibs = true;
49 fonts.fontconfig.enable = false;
50 # lesspipe does not cross-compile
51 programs.less.enable = lib.mkForce false;
52 programs.mosh.enable = false;
53 programs.traceroute.enable = false;
54 security.apparmor.enable = false;
55 services.udisks2.enable = false;
56 }