]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/mermet/prosody.nix
prosody: update to 0.12
[sourcephile-nix.git] / hosts / mermet / prosody.nix
1 { pkgs, lib, config, inputs, hosts, ipv4, ... }:
2 let
3 inherit (config.services) prosody;
4 inherit (hosts.mermet.config.services) coturn;
5 domain = config.networking.domain;
6 in
7 {
8 imports = [
9 prosody/biboumi.nix
10 ];
11 networking.nftables.ruleset = ''
12 add rule inet filter net2fw tcp dport {5222,5269} counter accept comment "XMPP"
13 add rule inet filter net2fw tcp dport 5000 counter accept comment "XMPP XEP-0065 File Transfer Proxy"
14 add rule inet filter net2fw tcp dport {${lib.concatMapStringsSep "," toString prosody.httpsPorts}} counter accept comment "XMPP HTTPS"
15 add rule inet filter fw2net meta skuid ${prosody.user} counter accept comment "Prosody"
16 '';
17 /*
18 services.upnpc.redirections =
19 [
20 { description = "XMPP";
21 externalPort = 5222; protocol = "TCP";
22 duration = 30 * 60;
23 service.wantedBy = ["prosody.service"];
24 service.partOf = ["prosody.service"];
25 }
26 { description = "XMPP";
27 externalPort = 5269; protocol = "TCP";
28 duration = 30 * 60;
29 service.wantedBy = ["prosody.service"];
30 service.partOf = ["prosody.service"];
31 }
32 { description = "XMPP-FTP";
33 externalPort = 5000; protocol = "TCP";
34 duration = 30 * 60;
35 service.wantedBy = ["prosody.service"];
36 service.partOf = ["prosody.service"];
37 }
38 ] ++ map (externalPort: {
39 description = "XMPP-HTTPS";
40 inherit externalPort; protocol="TCP";
41 duration = 30 * 60;
42 service.wantedBy = ["prosody.service"];
43 service.partOf = ["prosody.service"];
44 }) prosody.httpsPorts;
45 */
46 /*
47 services.tor.relay.hiddenServices."${domain}/xmpp".map = [ 5222 5269 5000 ] ++ prosody.httpsPorts;
48 */
49 users.groups.acme.members = [ prosody.user ];
50 security.acme.certs."${domain}" = {
51 postRun = "systemctl restart prosody";
52 };
53 fileSystems."/var/lib/prosody" = {
54 device = "rpool/var/prosody";
55 fsType = "zfs";
56 };
57 services.sanoid.datasets = {
58 "rpool/var/prosody" = {
59 use_template = [ "snap" ];
60 daily = 7;
61 };
62 };
63 systemd.services.prosody = {
64 wants = [ "acme-selfsigned-${domain}.service" "acme-${domain}.service"];
65 after = [ "acme-selfsigned-${domain}.service" ];
66 };
67 # sudo -u prosody prosodyctl check
68 services.prosody = {
69 enable = true;
70 xmppComplianceSuite = true;
71 modules = {
72 announce = true;
73 blocklist = true;
74 cloud_notify = true;
75 groups = true;
76 limits = false;
77 motd = true;
78 server_contact_info = true;
79 watchregistrations = true;
80 websocket = false;
81 welcome = true;
82 proxy65 = false;
83 };
84 extraModules = [
85 "turn_external"
86 "turncredentials"
87 #"net_multiplex"
88 #"extdisco"
89 ];
90 extraConfig = ''
91 log = {
92 -- debug = "*syslog";
93 info = "*syslog";
94 warn = "*syslog";
95 error = "*syslog";
96 }
97 -- Listen only in IPv4 until hosting provider's IPv6 works well.
98 interfaces = { "0.0.0.0" }
99 c2s_interfaces = { "0.0.0.0" }
100 contact_info = {
101 --abuse = { "mailto:abuse@${domain}", "xmpp:abuse@${domain}" };
102 --admin = { "mailto:admin@${domain}", "xmpp:admin@${domain}" };
103 --feedback = { "http://${domain}/feedback.php", "mailto:feedback@${domain}", "xmpp:feedback@${domain}" };
104 --sales = { "xmpp:bard@${domain}" };
105 --security = { "xmpp:security@${domain}" };
106 --support = { "http://${domain}/support.php", "xmpp:support@${domain}" };
107 }
108 legacy_ssl_ports = { 5222 }
109
110 turncredentials_host = "turn.${domain}"
111 turncredentials_port = 3478
112 turncredentials_secret = "${lib.removeSuffix "\n" (builtins.readFile (inputs.secrets + "/coturn/static-auth-secret"))}";
113
114 turn_external_secret = "${lib.removeSuffix "\n" (builtins.readFile (inputs.secrets + "/coturn/static-auth-secret"))}"
115 turn_external_host = ""turn.${domain}"
116 turn_external_port = 3478
117 turn_external_ttl = 86400
118
119 smacks_enabled_s2s = true;
120 smacks_s2s_resend = true;
121
122 --http_files_dir = "/var/lib/prosody/files"
123 --http_external_url = "https://tmp.${domain}:5281"
124 --https_certificate = "/var/lib/acme/${domain}/fullchain.pem"
125 --https_key = "/var/lib/acme/${domain}/key.pem"
126 --certificates = "/var/lib/acme"
127
128 proxy65_ports = 5000
129 Component "proxy65.${domain}" "proxy65"
130 proxy65_address = "proxy65.${domain}"
131 proxy65_acl = { "${domain}" }
132
133 Component "biboumi.${domain}"
134 component_secret = "useless-secret-on-loopback"
135
136 Component "tmp.${domain}" "http_file_share"
137 http_file_share_size_limit = 16*1024*1024 -- 16 MiB
138 http_file_share_daily_quota = 100*1024*1024 -- 100 MiB per day per user
139 http_file_share_global_quota = 1024*1024*1024 -- 1 GiB total
140 '';
141 #ports = {80};
142 #ssl_ports = {443};
143 c2sRequireEncryption = true;
144 s2sRequireEncryption = true;
145 s2sSecureAuth = true;
146 uploadHttp = {
147 domain = "tmp.${domain}";
148 # Prosody's HTTP parser limit on body size
149 uploadFileSizeLimit = "10485760";
150 userQuota = 100 * 1024 * 1024;
151 uploadExpireAfter = "60 * 60 * 24 * 7";
152 httpUploadPath = "/var/lib/prosody/upload";
153 };
154 muc = [
155 {
156 domain = "salons.${domain}";
157 extraConfig = ''
158 restrict_room_creation = "local"
159 max_history_messages = 42
160 muc_room_locking = true
161 muc_room_lock_timeout = 600
162 muc_tombstones = true
163 muc_tombstone_expiry = 31 * 24 * 60 * 60
164 muc_room_default_public = true
165 muc_room_default_members_only = false
166 muc_room_default_moderated = true
167 muc_room_default_public_jids = false
168 muc_room_default_change_subject = true
169 muc_room_default_history_length = 42
170 muc_room_default_language = "fr"
171 '';
172 }
173 ];
174 ssl.key = "/var/lib/acme/${domain}/key.pem";
175 ssl.cert = "/var/lib/acme/${domain}/fullchain.pem";
176 admins = [
177 "julm@${domain}"
178 ];
179 virtualHosts."${domain}" = {
180 enabled = true;
181 domain = "${domain}";
182 ssl.key = "/var/lib/acme/${domain}/key.pem";
183 ssl.cert = "/var/lib/acme/${domain}/fullchain.pem";
184 };
185 allowRegistration = false;
186 authentication = "internal_hashed";
187 httpPorts = [];
188 httpsPorts = [5281];
189 disco_items = [
190 { url = "biboumi.${domain}";
191 description = "Passerelle vers des serveurs IRC (Internet Relay Chat)"; }
192 ];
193 package = pkgs.prosody.override {
194 withCommunityModules = [
195 "turncredentials"
196 #"extdisco"
197 ];
198 };
199 };
200 }