]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/mermet/system.nix
mermet: lock machine-id
[sourcephile-nix.git] / hosts / mermet / system.nix
1 { pkgs, config, ... }:
2 {
3 # This value determines the NixOS release with which your system is to be
4 # compatible, in order to avoid breaking some software such as database servers.
5 # You should change this only after NixOS release notes say you should.
6 system.stateVersion = "19.09"; # Did you read the comment?
7
8 services.unbound.enable = true;
9
10 nix.gc.dates = "daily";
11 nix.gc.options = "--delete-older-than 2d";
12
13 # Setting the machine-id avoids to reencrypt all credentials
14 # when reinstalling NixOS on a new drive.
15 # Manually generated with : uuidgen | tr -d -
16 environment.etc.machine-id.source = ./machine-id.clear;
17
18 environment.systemPackages = with pkgs; [
19 cryptsetup
20 fio
21 git
22 gptfdisk
23 #hey
24 lm_sensors
25 rsync
26 socat
27 ];
28 }