3 inherit (config.users) users groups;
8 acme/sourcephile.fr.nix
10 networking.nftables.ruleset = ''
12 set output-net-lego-ipv4 { type ipv4_addr; }
13 set output-net-lego-ipv6 { type ipv6_addr; }
15 skuid ${users.acme.name} \
16 meta l4proto { udp, tcp } th dport domain \
17 ip daddr @output-net-lego-ipv4 \
20 skuid ${users.acme.name} \
21 meta l4proto { udp, tcp } th dport domain \
22 ip6 daddr @output-net-lego-ipv6 \
31 environment.systemPackages = [
36 home = "/var/lib/acme";
37 group = groups."acme".name;
38 # Set a static UID to install the credentialFile
39 # with acme:root perms before the system switch
44 { assertion = ! elem users.acme.uid (attrValues config.ids.uids);
46 Unix user ID ${toString users.acme.uid} is already taken in config.ids.uids: change for a free UID.