1 {pkgs, lib, config, system, ...}:
2 let inherit (lib) types;
5 domainBase = lib.mkOption {
7 description = "Base network name.";
10 domainAliases = lib.mkOption {
11 type = types.listOf types.str;
12 description = "Domain aliases.";
13 example = [ "example.org" "example.net" ];
15 zones = lib.mkOption {
16 type = types.attrsOf (types.submodule ({name, options, config, ...}: {
18 iface = lib.mkOption {
20 description = "Interface name.";
25 description = "Static IPv4 address of the machine.";
30 description = "Static IPv6 address of the machine.";