3 # This value determines the NixOS release with which your system is to be
4 # compatible, in order to avoid breaking some software such as database servers.
5 # You should change this only after NixOS release notes say you should.
6 system.stateVersion = "19.09"; # Did you read the comment?
8 boot.initrd.systemd = {
10 emergencyAccess = true; # FIXME: use a password
13 nix.gc.dates = "weekly";
14 nix.gc.options = "--delete-older-than 7d";
17 boot.binfmt.emulatedSystems = [ "aarch64-linux" ];
19 "https://nixcache.reflex-frp.org"
20 "https://arm.cachix.org"
22 nix.binaryCachePublicKeys = [
23 "ryantrinkle.com-1:JJiAKaRv9mWgpVAz8dwewnZe0AzzEAzPkagE9SP5NWI="
24 "arm.cachix.org-1:5BZ2kjoL1q6nWhlnrbAl+G7ThY7+HaBRD9PZzqZkbnM="
28 # Avoid the use of systemd-run --user --scope tmux
29 # and let mosh work smoothly.
30 services.logind.killUserProcesses = false;
32 hardware.bluetooth.enable = true;
33 #services.blueman.enable = true;
35 documentation.nixos = {
36 enable = false; # NOTE: useless on a server, and CPU intensive.
40 # Rotate the consoles anti-clockwise.
44 # Setting the machine-id avoids to reencrypt all credentials
45 # when reinstalling NixOS on a new drive.
46 # Manually generated with : uuidgen | tr -d -
47 environment.etc.machine-id.source = ./machine-id.clear;