1 { pkgs, lib, config, ... }:
3 hardware.cpu.intel.updateMicrocode = true;
5 # Too CPU hungry for the DL10J, for too little Mio saved
6 autoOptimiseStore = false;
9 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
11 # https://insanity.industries/post/sata-power-consumption/
12 services.udev.extraRules = ''
13 SUBSYSTEM=="scsi_host", KERNEL=="host*", ATTR{link_power_management_policy}="med_power_with_dipm"
21 configurationLimit = 3;
23 # Because canTouchEfiVariables doesn't work on this system
24 efiInstallAsRemovable = true;
26 # Completed in the importing configuration
30 { devices = [ "${disk_id}" ];
31 path = "/boot${bootnum}";
37 canTouchEfiVariables = false;
38 efiSysMountPoint = "/boot/efi";
43 availableKernelModules = [
45 "ehci_pci" # useless ?
47 "mei_me" # Communication controller
48 "nvme" # NVME M.2 disk
49 #"rtl8188ee" # Wireless
50 "rtsx_usb_sdmmc" # SD card
51 #"snd_hda_intel" # Audio
56 # Made the AES modules available at initrd,
57 # to speedup the deciphering of the root.
64 "nvme" # NVME M.2 disk
65 "rtsx_usb_sdmmc" # SD card
68 boot.kernelModules = [ ];
69 boot.extraModulePackages = [ ];
72 "console=ttyS0,115200n8"
73 "console=ttyS1,115200n8"
77 environment.systemPackages = with pkgs; [