]> Git — Sourcephile - sourcephile-nix.git/blob - base/install.nix
nix: rewrite deploy.sh into an install nix attribute
[sourcephile-nix.git] / base / install.nix
1 { pkgs, lib, config, ... }:
2 let inherit (lib) types; in
3 {
4 options = {
5 install.shellHook = lib.mkOption {
6 type = types.lines;
7 default = "";
8 };
9 # TODO: more structured options, like NixOps' deployment.keys
10 };
11 }