]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/mermet/system.nix
mermet: avoid sending nixpkgs input
[sourcephile-nix.git] / hosts / mermet / system.nix
1 { pkgs, lib, config, ... }:
2 {
3 # This value determines the NixOS release with which your system is to be
4 # compatible, in order to avoid breaking some software such as database servers.
5 # You should change this only after NixOS release notes say you should.
6 system.stateVersion = "19.09"; # Did you read the comment?
7
8 services.unbound.enable = true;
9
10 nix.gc.dates = "daily";
11 nix.gc.options = "--delete-older-than 2d";
12 nix.registry = lib.mkForce { };
13
14 # Setting the machine-id avoids to reencrypt all credentials
15 # when reinstalling NixOS on a new drive.
16 # Manually generated with : uuidgen | tr -d -
17 environment.etc.machine-id.source = ./machine-id.clear;
18
19 environment.systemPackages = with pkgs; [
20 cryptsetup
21 fio
22 git
23 gptfdisk
24 #hey
25 lm_sensors
26 rsync
27 socat
28 ];
29 }