1 # This is the root configuration of the target machine.
2 # Usable by nixos-install and used by nixops.
3 # It is NOT copied nor usable on the target machine,
4 # only the resulting closure is copied to the target machine.
5 { pkgs, lib, config, options, ... }@attrs:
7 inherit (builtins) getEnv hasAttr readFile;
8 inherit (builtins.extraBuiltins) pass pass-chomp;
11 # This value determines the NixOS release with which your system is to be
12 # compatible, in order to avoid breaking some software such as database servers.
13 # You should change this only after NixOS release notes say you should.
14 system.stateVersion = "19.09"; # Did you read the comment?
17 trustedUsers = [ "julm" ];
21 (./. + ("/" + getEnv "LOSURDO_DEPLOYMENT" + ".nix"))
23 ../../base/unbound.nix
24 ] ++ lib.optionals (! hasAttr "nodes" attrs) [
25 <nixops/share/nix/nixops/options.nix>
26 <nixops/share/nix/nixops/resource.nix>
31 domainBase = "sourcephile";
32 domain = "${domainBase}.fr";
36 environment.etc."sudo.conf".text = ''
37 Debug sudo /var/log/sudo_debug.log all@debug
38 Debug sudoers.so /var/log/sudo_debug.log all@debug
46 openssh.authorizedKeys.keys = [
47 (readFile ../../../sec/ssh/julm.pub)
48 (readFile ../../../sec/ssh/julm-mob.pub)
53 hashedPassword = pass-chomp "servers/losurdo/login/julm/hashedPassword";
55 openssh.authorizedKeys.keys = [
56 (readFile ../../../sec/ssh/julm.pub)
57 (readFile ../../../sec/ssh/julm-mob.pub)
58 #(readFile ../../../sec/ssh/julm-losurdo.pub)
73 systemd.coredump.enable = true;
76 enableDebugInfo = true;
77 systemPackages = with pkgs; [