]> Git — Sourcephile - sourcephile-nix.git/blob - servers/losurdo/production/dl10j.nix
losurdo: running configuration
[sourcephile-nix.git] / servers / losurdo / production / dl10j.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ../../../base/dl10j.nix
5 ];
6
7 boot.loader.grub.devices = [
8 "/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
9 ];
10
11 fileSystems."/boot" =
12 { device = "/dev/disk/by-uuid/0ea6842a-9e95-45ce-b2a9-8639918875f3";
13 fsType = "ext2";
14 };
15
16 fileSystems."/boot/efi" =
17 { device = "/dev/disk/by-uuid/6BB1-D61E";
18 fsType = "vfat";
19 };
20
21 swapDevices =
22 [ { device = "/dev/disk/by-partuuid/a0bd2fd9-2df3-4626-bc7b-db9da714eba5";
23 randomEncryption = {
24 enable = true;
25 cipher = "aes-xts-plain64";
26 source = "/dev/urandom";
27 };
28 }
29 ];
30
31 environment = {
32 systemPackages = with pkgs; [
33 pciutils
34 flashrom
35 ];
36 };
37 }