1 { pkgs, lib, config, ... }:
8 autoOptimiseStore = true;
11 # Use gc.automatic to keep disk space under control.
15 options = "--delete-older-than 30d";
23 packageOverrides = pkgs: {
24 postfix = pkgs.postfix.override {
30 #overlays = import ../overlays.nix;
33 documentation.nixos = {
34 enable = false; # NOTE: useless on this machine, and CPU intensive.
38 timeZone = "Europe/Paris";
42 consoleFont = "Lat2-Terminus16";
44 defaultLocale = "fr_FR.UTF-8";
61 systemPackages = with pkgs; [
76 etc."inputrc".text = lib.readFile defaults/readline/inputrc;
81 interactiveShellInit = ''
82 bind '"\e[A":history-search-backward'
83 bind '"\e[B":history-search-forward'
85 # Ignore duplicate commands, ignore commands starting with a space
86 export HISTCONTROL=erasedups:ignorespace
89 # Append to the history instead of overwriting (good for multiple connections)
96 ls = "ls --color=tty";
99 s-u="systemctl --user";
101 nixos-clean="sudo nix-collect-garbage -d";
102 nixos-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
103 nixos-rollback="sudo nixos-rebuild switch --rollback";
104 nixos-update="sudo nix-channel --update";
105 nixos-upgrade="sudo nixos-rebuild switch";
106 nixos-upstream="sudo nix-channel --list";