]> Git — Sourcephile - sourcephile-nix.git/blob - servers/mermet.nix
nix: revamp the hierarchy (again)
[sourcephile-nix.git] / servers / mermet.nix
1 # This is the root configuration of the target machine.
2 # Usable by nixos-install and used by nixops.
3 # It is NOT copied nor usable on the target machine,
4 # only the resulting closure is copied to the target machine.
5 {pkgs, lib, config, options, nodes, resources, ...}:
6 let
7 deployment = builtins.getAttr
8 (lib.maybeEnv "NIXOPS_DEPLOYMENT" "production")
9 deployments;
10 deployments = {
11 maintenance = [
12 mermet/machine/apu2e4.nix
13 mermet/hosting/lan.nix
14 ];
15 production = [
16 mermet/machine/apu2e4.nix
17 mermet/hosting/ptt.nix
18 ];
19 staging = [
20 mermet/machine/virtualbox.nix
21 mermet/hosting/localhost.nix
22 ];
23 };
24 in
25 {
26 nixpkgs.overlays = import ../overlays.nix;
27 imports =
28 [ ../nixos/defaults.nix
29 mermet/system.nix
30 ] ++ deployment;
31 }