]> Git — Sourcephile - sourcephile-nix.git/blob - servers/mermet/system.nix
mermet: install flashrom
[sourcephile-nix.git] / servers / mermet / system.nix
1 { config, lib, pkgs, options, ... }:
2 let inherit (builtins.extraBuiltins) pass;
3 in
4 {
5 imports =
6 [ ./system/zfs.nix
7 ];
8
9 # This value determines the NixOS release with which your system is to be
10 # compatible, in order to avoid breaking some software such as database
11 # servers. You should change this only after NixOS release notes say you should.
12 system.stateVersion = "19.09"; # Did you read the comment?
13
14 # Clean /tmp automatically on boot.
15 boot.cleanTmpDir = true;
16
17 networking = {
18 hostName = "mermet";
19 domain = "sourcephile.fr";
20 };
21
22 users = {
23 mutableUsers = false;
24 users = {
25 root = rec {
26 initialPassword = password;
27 password = pass "servers/mermet/login/root";
28 openssh.authorizedKeys.keys = [
29 (pass "members/julm/ssh.pub")
30 ];
31 };
32 };
33 groups = {
34 };
35 };
36
37 environment = {
38 systemPackages = with pkgs; [
39 cryptsetup
40 zfs
41 ];
42 };
43 }