]> Git — Sourcephile - sourcephile-nix.git/blob - servers/losurdo/system.nix
nix: split configuration.nix into alternative toplevels
[sourcephile-nix.git] / servers / losurdo / system.nix
1 { pkgs, lib, config, ... }:
2 {
3 # This value determines the NixOS release with which your system is to be
4 # compatible, in order to avoid breaking some software such as database servers.
5 # You should change this only after NixOS release notes say you should.
6 system.stateVersion = "19.09"; # Did you read the comment?
7
8 environment.systemPackages = with pkgs; [
9 cryptsetup
10 direnv
11 file
12 fio
13 gdb
14 git
15 gptfdisk
16 #hey
17 home-manager
18 lm_sensors
19 rsync
20 smartctl-tbw
21 socat
22 sanoid
23 ];
24 }