1 { inputs, pkgs, lib, config, ... }:
2 let inherit (lib) types;
3 inherit (config.networking) hostName domain;
9 defaults/predictable-interface-names.nix
12 #binaryCaches = lib.mkForce [];
15 # Use gc.automatic to keep disk space under control.
17 automatic = lib.mkDefault true;
18 dates = lib.mkDefault "weekly";
19 options = lib.mkDefault "--delete-older-than 30d";
22 # WARNING: this is a hack to avoid copying Nixpkgs
23 # a second time into the Nix store.
24 # It makes only sense when Nixpkgs is already in the Nix store,
26 "nixpkgs=/etc/nixpkgs:nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
29 environment.etc."nixpkgs".source = pkgs.path;
30 environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
36 packageOverrides = pkgs: {
37 postfix = pkgs.postfix.override {
45 documentation.nixos = {
46 enable = false; # NOTE: useless on a server, and CPU intensive.
50 timeZone = "Europe/Paris";
54 defaultLocale = "fr_FR.UTF-8";
58 font = "Lat2-Terminus16";
62 # Always try to start all the units (default.target)
63 # because systemd's emergency shell does not try to start sshd.
64 # https://wiki.archlinux.org/index.php/systemd#Disable_emergency_mode_on_remote_host
65 systemd.enableEmergencyMode = false;
67 # This is a remote headless server: always reboot on a kernel panic,
68 # to not have to physically go power cycle the apu2e4.
69 # Which happens if the wrong ZFS password is used
70 # but the boot is manually forced to continue.
71 # Using kernelParams instead of kernel.sysctl
72 # sets this up as soon as the initrd.
73 boot.kernelParams = [ "panic=10" ];
75 boot.cleanTmpDir = true;
76 boot.tmpOnTmpfs = true;
80 # See: https://github.com/NixOS/nixpkgs/issues/10183#issuecomment-537629621
82 "127.0.1.1" = lib.mkForce [ "${hostName}.${domain}" hostName ];
83 "::1" = lib.mkForce [ "${hostName}.${domain}" hostName "localhost" ];
86 usePredictableInterfaceNames = true;
92 passwordAuthentication = false;
99 MaxRetentionSec=1month
106 environment.systemPackages = with pkgs; [
118 linuxPackages.cpupower
138 environment.variables.SYSTEMD_LESS = "FKMRX";
139 environment.etc."inputrc".text = lib.readFile defaults/readline/inputrc;
143 interactiveShellInit = ''
144 bind '"\e[A":history-search-backward'
145 bind '"\e[B":history-search-forward'
147 # Ignore duplicate commands, ignore commands starting with a space
148 export HISTCONTROL=erasedups:ignorespace
149 export HISTSIZE=42000
151 # Append to the history instead of overwriting (good for multiple connections)
154 # Enable ** file pattern
157 # Convenient mkdir wrapper
158 mkcd() { mkdir -p "$1" && cd "$1"; }
164 ls = "ls --color=tty";
165 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
168 st="sudo systemctl status";
169 s-u="systemctl --user";
170 j="sudo journalctl -u";
172 nixos-clean="sudo nix-collect-garbage -d";
173 nixos-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
174 nixos-rollback="sudo nixos-rebuild switch --rollback";
175 nixos-update="sudo nix-channel --update";
176 nixos-upgrade="sudo nixos-rebuild switch";
177 nixos-upstream="sudo nix-channel --list";
182 pinentryFlavor = "curses";
187 traceroute.enable = true;